Download it now!
Bug 109144 - FILESAVE XLSX: Resaving file with autofilter on conditional formatting results in invalid XLSX
Summary: FILESAVE XLSX: Resaving file with autofilter on conditional formatting result...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.4.0.1 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Conditional-Formatting XLSX-Corrupted
  Show dependency treegraph
 
Reported: 2017-07-16 16:35 UTC by Gabor Kelemen
Modified: 2017-09-17 14:30 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file with autofilter and conditional format (8.94 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2017-07-16 16:35 UTC, Gabor Kelemen
Details
Same file resaved from 5.4 (6.27 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2017-07-16 16:36 UTC, Gabor Kelemen
Details
The two example files in Excel 2013 (66.43 KB, image/png)
2017-07-16 16:36 UTC, Gabor Kelemen
Details
Same file saved with Excel 2010 (8.88 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2017-07-17 10:41 UTC, Gabor Kelemen
Details
File from Excel 2010 modified by LO 5.4 (6.30 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2017-07-17 10:41 UTC, Gabor Kelemen
Details
The file made in Excel 2010 and its modified version in Excel 2013 (59.12 KB, image/png)
2017-07-17 10:46 UTC, Gabor Kelemen
Details
The example file from Excel2013 saved from LO6 alpha (6.28 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2017-09-16 14:55 UTC, Gabor Kelemen
Details
Screenshot of the original file and the exported one in Excel 2013 (227.28 KB, image/jpeg)
2017-09-16 14:57 UTC, Gabor Kelemen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kelemen 2017-07-16 16:35:53 UTC
Created attachment 134667 [details]
Example file with autofilter and conditional format

Attached file was made with Excel 2013 and contains a few numbers with a simple conditional format set: red font and strikethrough if value <= 100.
It also contains an autofilter above these numbers.

Opening in 5.4RC1 and saving with another file name creates a file with "unreadable content" in Excel 2013.
Comment 1 Gabor Kelemen 2017-07-16 16:36:22 UTC
Created attachment 134668 [details]
Same file resaved from 5.4
Comment 2 Gabor Kelemen 2017-07-16 16:36:50 UTC
Created attachment 134669 [details]
The two example files in Excel 2013
Comment 3 Xisco Faulí 2017-07-17 09:32:42 UTC Comment hidden (obsolete)
Comment 4 Gabor Kelemen 2017-07-17 10:37:40 UTC
I cannot reproduce it with a file saved by Excel 2010 either.

Maybe 2013 does not exactly write the same content? 
For reference, I attach files created in Excel 2010, modified in LO 5.4 and their appearance in Excel 2013.
Comment 5 Gabor Kelemen 2017-07-17 10:41:17 UTC
Created attachment 134678 [details]
Same file saved with Excel 2010
Comment 6 Gabor Kelemen 2017-07-17 10:41:48 UTC
Created attachment 134679 [details]
File from Excel 2010 modified by LO 5.4
Comment 7 Gabor Kelemen 2017-07-17 10:46:34 UTC
Created attachment 134680 [details]
The file made in Excel 2010 and its modified version in Excel 2013

No obvious problem visible.
Comment 8 Gabor Kelemen 2017-09-16 14:55:38 UTC
Created attachment 136287 [details]
The example file from Excel2013 saved from LO6 alpha
Comment 9 Gabor Kelemen 2017-09-16 14:57:45 UTC
Created attachment 136288 [details]
Screenshot of the original file and the exported one in Excel 2013

Still not good, the original file is exported in a way that causes a dataloss error in Excel.
Comment 10 Aron Budea 2017-09-17 04:02:51 UTC
(In reply to Gabor Kelemen from comment #9) 
> Still not good, the original file is exported in a way that causes a
> dataloss error in Excel.

I get no error in Excel 2013 after roundtripping the original spreadsheet (attachment 134667 [details]) with LO 6.0 daily build (2017-09-14_00:10:31, f70e0ec6b3c61a7c7caa469949b0ac8016c89854). The entries also appear the same as in the original file.
Comment 11 Xisco Faulí 2017-09-17 09:40:59 UTC Comment hidden (obsolete)
Comment 12 Yousuf Philips (jay) (retired) 2017-09-17 14:30:43 UTC
(In reply to Gabor Kelemen from comment #1)
> Created attachment 134668 [details]
> Same file resaved from 5.4

Yes opening this file in Excel 2013 does give an error as it was produced with LO 5.4.0 rc1, but 5.4.0 rc2 or rc3 and 5.4.1.2 dont produce this same error when saving attachment 134667 [details] and opening it in Excel 2013, so please upgrade.

(In reply to Gabor Kelemen from comment #8)
> Created attachment 136287 [details]
> The example file from Excel2013 saved from LO6 alpha

Yes this file also produces the same error, but not sure which build date your version is from (you can find the build information in the Help > About dialog), but my version below from last month doesnt cause the error.

Version: 6.0.0.0.alpha0+
Build ID: 7f4e02e3809e10564bd2bb91465c99f4dd207da7
CPU threads: 4; OS: Windows 6.29; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-08-29_22:58:12
Locale: en-US (en_US); Calc: group

There is a recent regression in 6.0 master since last month that is causing an error in Excel 2013 and that is being handled in bug 112444.