Download it now!
Bug 109154 - On Mac OS I can't type russian letter Yo (ё) by long pressing russian Ye (е).
Summary: On Mac OS I can't type russian letter Yo (ё) by long pressing russian Ye (е).
Status: RESOLVED DUPLICATE of bug 42437
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.4.2 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-07-17 10:50 UTC by Dmitry
Modified: 2017-08-08 15:11 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry 2017-07-17 10:50:38 UTC
Description:
In standard text editor TextEdit if I long press russian Ye (е), small popup window appears that shows this letter with diacritics (ё) that I can select. If I try the same in Libre Office Writer, the letter Ye (е) is simply repeated, which I don't need.
I guess it is Mac-specific issue.

Steps to Reproduce:
1. On Mac OS add russian keyboard (Russian - PC).
2. Launch the Writer (create empty document).
3. Switch to russian keyboard.
4. Long press russian Ye (е) - this key is located on the same key where english 'T'.
5. You will see that the letter is repeating. On Mac I expect that a popup window appears asking me to select letter with diacritics (ё).
To understand behavior that I expect please do the same in standard TextEdit application.

Actual Results:  
the letter is repeating

Expected Results:
On Mac I expect that a popup window appears asking me to select letter with diacritics (ё).


Reproducible: Always

User Profile Reset: No

Additional Info:
version info of the software:
Version: 5.3.4.2
Build ID: f82d347ccc0be322489bf7da61d7e4ad13fe2ff3
CPU Threads: 8; OS Version: Mac OS X 10.11.5; UI Render: default; Layout Engine: new; 
Locale: en-US (en.UTF-8); Calc: group



User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_5) AppleWebKit/601.6.17 (KHTML, like Gecko) Version/9.1.1 Safari/601.6.17
Comment 1 Roman Kuznetsov 2017-08-07 19:27:17 UTC
Try type russian letter Yo (ё) by long pressing russian Ye (е) in another non macOS software
Comment 2 rami 2017-08-07 19:55:05 UTC
Similar behavior is also observed in Apache OpenOffice and other third-party programs.
Comment 3 Xisco Faulí 2017-08-07 23:00:35 UTC
(In reply to rami from comment #2)
> Similar behavior is also observed in Apache OpenOffice and other third-party
> programs.

Third-party programs not related to LibreOffice/OpenOffice? then I assume the bug must be somewhere else. You should try looking for it in the internet.
Closing as RESOLVED NOTOURBUG
Comment 4 Adolfo Jayme 2017-08-08 15:11:01 UTC
This is our bug, tho.

*** This bug has been marked as a duplicate of bug 42437 ***