Bug 109183 - Long Freezes After System Timer Update
Summary: Long Freezes After System Timer Update
Status: RESOLVED DUPLICATE of bug 109123
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2017-07-18 05:03 UTC by Luke
Modified: 2017-07-20 17:39 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Test Spreadsheet to demonstrate the bug (1.13 MB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2017-07-18 05:03 UTC, Luke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2017-07-18 05:03:51 UTC
Created attachment 134704 [details]
Test Spreadsheet to demonstrate the bug

I noticed several spreadsheets are become unresponsive when scrolling with the keyboard. 

Steps to Reproduce
1. With a recent build of libreoffice open the attachment
2. Put the cursor in N1
3. Press the down arrow to make the screen scroll

Actual Results:
1. Usually by the time you hit N39, the LibreOffice UI will freeze and become unresponsive for several minutes.

I was able to reproduce this on a Win 10 desktop and laptop with 64bit builds. So far I have bisected the regression down to this range:

https://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=dc63cc326ee5757124cef45e470d290e6e32002e..51bb68928933bf5d72efb9193f1be6af6e72c80f+
Comment 1 Luke 2017-07-18 06:45:43 UTC
Also seeing this on: Version: 6.0.0.0.alpha0+
Build ID: 7a743b472dadb817eb7a6ed8063cee80ce7412e8
CPU threads: 4; OS: Windows 6.19; UI render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-07-17_23:50:28

So it affects both x86 and x86-64.
Comment 2 Telesto 2017-07-18 20:38:45 UTC
Repro with:
Version: 6.0.0.0.alpha0+
Build ID: 7a743b472dadb817eb7a6ed8063cee80ce7412e8
CPU threads: 4; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-07-17_23:50:28
Locale: nl-NL (nl_NL); Calc: CL
Comment 3 Luke 2017-07-19 07:06:41 UTC
I bisected this regression down to this commit:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=5229f15904b42238273d1fa98ca8dcf6efda48f5

WIN simplify system timer / LO event handling

Jan-Marek Glogowski,
Could you please take a look at this?
Comment 4 Jan-Marek Glogowski 2017-07-20 17:39:14 UTC

*** This bug has been marked as a duplicate of bug 109123 ***