Download it now!
Bug 109227 - Image disappears on crop and compress
Summary: Image disappears on crop and compress
Status: RESOLVED DUPLICATE of bug 99286
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2.7.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.0.0
Keywords: bibisectRequest, regression
Depends on:
Blocks:
 
Reported: 2017-07-20 07:59 UTC by internationils
Modified: 2017-08-04 17:16 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description internationils 2017-07-20 07:59:12 UTC
Description:
Image disappears when cropping and compressing

Also reproduced in https://bugs.documentfoundation.org/show_bug.cgi?id=99050#c24

Steps to Reproduce:
- import the image (.jpg)
- crop it (IMPORTANT: without cropping the pic does not disappear!)
- compress it
- gone

Actual Results:  
Image disappears

Expected Results:
Image visible


Reproducible: Always

User Profile Reset: No

Additional Info:
Also:
- first compressing, then cropping appears to work and not blank the picture
- first compressing, then cropping, then compressing some more (600->150->96dpi) also seems to work normally

Version: 5.2.7.2
Build ID: 1:5.2.7-1
CPU Threads: 2; OS Version: Linux 4.9;

Version: 5.3.4.2 (x64)
Build-ID: f82d347ccc0be322489bf7da61d7e4ad13fe2ff3
CPU-Threads: 4; BS-Version: Windows 6.1

Version: 5.4.0.2 (x64)
Build-ID: 2b906d450a44f2bbe506dcd22c51b3fa11dc65fd
CPU-Threads: 4; Betriebssystem:Windows 6.1


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 internationils 2017-07-20 07:59:49 UTC
Setting to NEW per https://bugs.documentfoundation.org/show_bug.cgi?id=99050#c27
Comment 2 raal 2017-07-23 21:09:01 UTC

*** This bug has been marked as a duplicate of bug 99286 ***
Comment 3 Commit Notification 2017-07-27 08:31:13 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0c840d9bf308464d58a2df8aaa1e61481b5e4f52

gtk3: Resolves: tdf#109227 take modifier key into account for dnd

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 internationils 2017-08-03 08:30:13 UTC
Apparently the proposed patch doesn't fix the problem:
https://bugs.documentfoundation.org/show_bug.cgi?id=99286#c13
Comment 5 Adolfo Jayme 2017-08-04 17:16:03 UTC
That would be because the patch meant to reference bug 109277 instead. It was a typo.