Download it now!
Bug 109257 - EDITING UI Drawing interface is very slow
Summary: EDITING UI Drawing interface is very slow
Status: RESOLVED DUPLICATE of bug 105500
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
5.3.4.2 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: Draw-UX
  Show dependency treegraph
 
Reported: 2017-07-21 13:17 UTC by Pierre-Alain Dorange
Modified: 2017-11-18 16:02 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pierre-Alain Dorange 2017-07-21 13:17:00 UTC
I recently upgrade my Mac, so i do with MacOS (from 10.6 to 10.12) and LibreOffice (from 4 to 5).

Unfortunnaly the experience is bad. LibreOffice seems less responsiveness and the worth was with Draw Module.

Using Draw, each clic to select an object take from 1 to 2 seconds to select the object. When selected all seems right (dragging, sizing are fine in speed).
But each selection is very slow : making Draw module unpraticable.
I have to launch LibreOffice 4 to edit drawings !

Deselection is also slow (but not as slow as selection).

Step to reproduce :
1. Draw 2 rectangles
2. De-select (clip empty space)
3. select 1 rectangle
4. (wait 1-2 seconds defore it was select)
5. select the other rectangle and drag it
6. you've finished dragging the selection was still not done, then the movement occured

This make the draw module (in this config) not usable.
Comment 1 Telesto 2017-07-21 14:12:57 UTC
LibreOffice performance on MacOS (Sierra) is general not good (see for example bug 106154 and bug 106703). It's accumulating with bug 105500 -> Try disabling the Sidebar (Menu View -> Sidebar). Draw should respond faster.

Another option is to use a older version. As far I heard LibO 5.1.6.2 should work fine: https://downloadarchive.documentfoundation.org/libreoffice/old/5.1.6.2/mac/x86_64/

If you want to run LibO for a few weeks in a row, try LibO4.3.7.2.  https://downloadarchive.documentfoundation.org/libreoffice/old/4.3.7.2/mac/x86_64/
Comment 2 Alex Thurgood 2017-07-21 15:04:45 UTC
Confirming, as I had the annoying misfortune to have to suffer from this just the other day with LO5332.

I think this was already reported somewhere though, so possibly a DUP.
Comment 3 Alex Thurgood 2017-07-21 15:11:27 UTC
(In reply to Telesto from comment #1)
> LibreOffice performance on MacOS (Sierra) is general not good (see for
> example bug 106154 and bug 106703). It's accumulating with bug 105500 -> Try
> disabling the Sidebar (Menu View -> Sidebar). Draw should respond faster.
> 
> Another option is to use a older version. As far I heard LibO 5.1.6.2 should
> work fine:
> https://downloadarchive.documentfoundation.org/libreoffice/old/5.1.6.2/mac/
> x86_64/


Yes, this still runs at an acceptable speed.
Comment 4 Pierre-Alain Dorange 2017-07-21 15:50:30 UTC
(In reply to Telesto from comment #1)
> LibreOffice performance on MacOS (Sierra) is general not good (see for
> example bug 106154 and bug 106703). It's accumulating with bug 105500 -> Try
> disabling the Sidebar (Menu View -> Sidebar). Draw should respond faster.
> 
> Another option is to use a older version. As far I heard LibO 5.1.6.2 should
> work fine:
> https://downloadarchive.documentfoundation.org/libreoffice/old/5.1.6.2/mac/
> x86_64/
> 
> If you want to run LibO for a few weeks in a row, try LibO4.3.7.2. 
> https://downloadarchive.documentfoundation.org/libreoffice/old/4.3.7.2/mac/
> x86_64/

Yes you're right, closing the sidebar it became reponsive !
But using Draw without the sideview is not very ergonomic.
Comment 5 Telesto 2017-11-18 16:02:36 UTC
> Yes you're right, closing the sidebar it became reponsive !
> But using Draw without the sideview is not very ergonomic.

So a duplicate of bug 105500

*** This bug has been marked as a duplicate of bug 105500 ***