Bug 109328 - EDITING: Cannot paste text in input field placed inside protected section
Summary: EDITING: Cannot paste text in input field placed inside protected section
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.3.2 release
Hardware: x86-64 (AMD64) All
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Paste Fields
  Show dependency treegraph
 
Reported: 2017-07-25 03:01 UTC by Rodrigo Castanheira
Modified: 2020-01-14 14:53 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rodrigo Castanheira 2017-07-25 03:01:54 UTC
Description:
When an input field is placed inside a protected section, pasting to the input field stops working. Similar behaviour was reported 3 years ago in this AAO forum thread: https://forum.openoffice.org/en/forum/viewtopic.php?f=7&t=70135

Steps to Reproduce:
1. Create a new Writer document.
2. Add a section (unprotected).
3. Place an input field inside the section.
4. Copy some text to the clipboard.
5. Move cursor inside the input field and paste text - it works as expected.
6. Protect the section containing the input field.
7. Move cursor inside the input field and try to paste text again - nothing happens this time.

Actual Results:  
After protecting the section containing the input field, pasting to the input field stopped working.

Expected Results:
Pasting text to input fields should work even when they are placed inside a protected section. They are frequently used this way in application forms, for example.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/59.0.3071.115 Safari/537.36
Comment 1 Buovjaga 2017-08-14 18:47:46 UTC
Confirmed.

This seems like easy hack material.

A related fix: https://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-4-3-3&id=dfde5b967b27d9a44f35ce96cf99554722985bc5

Arch Linux 64-bit, KDE Plasma 5
Version: 6.0.0.0.alpha0+
Build ID: a7ed6a9731f0101fe1454638135bb30f5dcb4f88
CPU threads: 8; OS: Linux 4.12; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on August 14th 2017
Comment 2 QA Administrators 2018-08-15 02:33:10 UTC Comment hidden (obsolete)
Comment 3 Rodrigo Castanheira 2018-08-16 04:51:11 UTC
Bug is still present - if you move the cursor in an input field (single click to select followed by another single click) which is placed inside a protected section and then try to paste text from clipboard, nothing happens. On the other hand, if the section is not protected, pasting works as expected.

Nevertheless, since version 6.0 (tdf#79877), double clicking on input fields opens an input dialog where pasting works, even when the input field is placed inside a protected section.

Version: 6.1.0.3 (x64); SO:Windows 10.0; locale: pt-BR
Comment 4 QA Administrators 2019-08-19 06:55:28 UTC Comment hidden (obsolete)
Comment 5 Rodrigo Castanheira 2019-09-07 16:00:08 UTC
Bug is still present, albeit there is a workaround described in comment #3.

6.2.5.2 (x64)
1ec314fa52f458adc18c4f025c545a4e8b22c159
Windows 10.0
pt-BR (pt_BR)
Comment 6 sdc.blanco 2020-01-03 12:48:46 UTC
Works for me  (i.e., can change text in an input field placed in a write protected section)

Version: 6.5.0.0.alpha0+ (x64)
Build ID: 444f0d256957544d26b9af9a0898364e829df1b5
CPU threads: 8; OS: Windows 10.0 Build 18363; UI render: GL; VCL: win; 
Locale: en-US (en_DK); UI-Language: en-US
Calc: threaded
Comment 7 Buovjaga 2020-01-14 14:53:03 UTC
I guess we should close. Pasting without invoking the field editing dialog does not paste into the field contents anyway. It pastes normal text.