Bug Hunting Session
Bug 109999 - Malayalam text formating Rendering Problem with New Layout Engine LibreOffice Writer 5.3.x.x onwards
Summary: Malayalam text formating Rendering Problem with New Layout Engine LibreOffice...
Status: RESOLVED DUPLICATE of bug 105913
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: x86 (IA32) All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: HarfBuzz-regressions Paragraph
  Show dependency treegraph
 
Reported: 2017-07-29 09:09 UTC by Ramesh K
Modified: 2017-10-30 12:48 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
PDF File (40.75 KB, application/pdf)
2017-07-29 09:09 UTC, Ramesh K
Details
Sample Text related with bug (20.79 KB, application/vnd.oasis.opendocument.text)
2017-10-22 17:32 UTC, Ramesh K
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ramesh K 2017-07-29 09:09:58 UTC
Created attachment 134967 [details]
PDF File

When applying justifying format to paragaph which containg malayalam unicode characters,unwanted Trailing space appearing at the end of a paragraph line. Kindly go through the attachment.
Comment 1 Ramesh K 2017-07-29 09:25:53 UTC
word breaking with Zero Width Joiner unicode character in a paragaph which containg malayalam unicode characters.
Comment 2 Xisco Faulí 2017-07-31 19:51:47 UTC
Moving it back to UNCONFIRMED until someone else confirms it.
Comment 4 K Premkumar 2017-10-11 09:52:30 UTC
I have been having this problem from Writer 5.3 onwards. Because of this problem, I am unable to use LO for Malayalam documents on Windows, or I will have to move back to Writer version 5.2. 

I am not sure if the problem exists in Linux. Also, is this the same as bug 105913? https://bugs.documentfoundation.org/show_bug.cgi?id=105913
Comment 5 Ramesh K 2017-10-21 18:07:30 UTC
Well maintained and popular malayalam unicode fonts are available at https://smc.org.in/fonts/ and its source codes are available at https://gitlab.com/smc for further reference. 

The info obtained from https://ask.libreoffice.org/en/question/135020/malayalam-text-formating-rendering-problem-with-libreoffice-writer-536-and-542/?answer=135115#post-id-135115 is help to take necessary action to solve it. 

"With 5.4.0.3 on Windows and Meera regular font, when a line ends in U+0D26U+0D46 there is extra space. Perhaps when the glyphs are drawn in reverse order, the engine fails to determine where to add spacing.

Apache OpenOffice 4.1.3 does not show extra space. LibreOffice introduced a new layout engine starting in 5.3, as explained at One of the main goals was to use a single engine across all platforms, rather than Uniscribe only on Windows."
Comment 6 Ramesh K 2017-10-22 17:32:46 UTC
Created attachment 137209 [details]
Sample Text related with bug
Comment 7 Telesto 2017-10-22 18:48:42 UTC
There is a easy workaround for the LibO5.3 branch only, if it's related to the new layout engine:

Tools -> Options -> Advanced: Expert Configuration search for "TextLayoutEngine" and edit to change "new|old" as needed. (Source: bug 89870 comment 32)
Comment 8 Khaled Hosny 2017-10-30 07:49:25 UTC

*** This bug has been marked as a duplicate of bug 105913 ***