Download it now!
Bug 110461 - Letter page format size prints portrait pages as landscape on OS X (template dependent)
Summary: Letter page format size prints portrait pages as landscape on OS X (template ...
Status: RESOLVED DUPLICATE of bug 92190
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.5.1 rc
Hardware: x86-64 (AMD64) Mac OS X (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 110460 111445 111909 112234 112339 112361 112432 112600 113167 113710 (view as bug list)
Depends on:
Blocks: Print
  Show dependency treegraph
 
Reported: 2017-07-31 14:27 UTC by Al Maloney
Modified: 2017-12-08 07:36 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments
Affected template (10.05 KB, application/vnd.oasis.opendocument.text-template)
2017-07-31 14:28 UTC, Al Maloney
Details
Unaffected template (17.69 KB, application/vnd.oasis.opendocument.text-template)
2017-07-31 14:29 UTC, Al Maloney
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Al Maloney 2017-07-31 14:27:17 UTC
Description:
See comment #52 of Bug 86838

When attempting to print a Writer portrait document, it prints rotated 90 degrees (= landscape).

The problem exists in 5.3.5.X and 5.4.0.x
Using macOS 10.12.6 on a MacBook Pro and an iMac
It does not happen with 5.2.7, nor with 5.3.4


Version: 5.3.5.1
Build ID: 020db1aa8142e57290f8a21e4df31185392d0e38
CPU Threads: 4; OS Version: Mac OS X 10.12.6; UI Render: default; Layout Engine: new; 
Locale: en-CA (en_US.UTF-8); Calc: group
Version: 5.4.0.3
Build ID: 7556cbc6811c9d992f4064ab9287069087d7f62c
CPU threads: 4; OS: Mac OS X 10.12.6; UI render: default; 
Locale: en-CA (en_US.UTF-8); Calc: group


It seems to depend upon which of my templates I am using (of 40 or so templates).

For a given affected document, switching page size to anything other than Letter resolves the problem until I return to Letter size.

When I check File->Properties for an affected template and for an unaffected template, I can find no difference.
So…I do not know where to go from here.



Affected template – AM_Num.ott, also the default Text Document set in the Template Manager
Unaffected template – TryThis.ott

Steps to Reproduce:
1.Open Writer document 
2.Attempt to print Letter size in Portrait view
3.

Actual Results:  
Document is rotated 90° to Landscape view

Expected Results:
Document exhibited in Portrait view


Reproducible: Always

User Profile Reset: Yes. Problem persists.

Additional Info:


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:55.0) Gecko/20100101 Firefox/55.0
Comment 1 Al Maloney 2017-07-31 14:28:51 UTC
Created attachment 135022 [details]
Affected template
Comment 2 Al Maloney 2017-07-31 14:29:42 UTC
Created attachment 135023 [details]
Unaffected template
Comment 3 Julien Nabet 2017-07-31 15:21:13 UTC

*** This bug has been marked as a duplicate of bug 110460 ***
Comment 4 Al Maloney 2017-07-31 16:01:39 UTC
(In reply to Julien Nabet from comment #3)
> 
> *** This bug has been marked as a duplicate of bug 110460 ***

How can it be a system printer driver problem when the problem does not occur with earlier version of LibreOffice?

Al Maloney
Comment 5 Telesto 2017-09-12 06:38:17 UTC

*** This bug has been marked as a duplicate of bug 92190 ***
Comment 6 Telesto 2017-10-09 17:55:54 UTC
I'm reopening this one. This bug is introduced between LibO 5.3.4.2 and 5.3.5.1 and not directly related to bug 92190
Comment 7 Telesto 2017-10-09 18:06:05 UTC
*** Bug 110460 has been marked as a duplicate of this bug. ***
Comment 8 Telesto 2017-10-09 18:06:27 UTC
*** Bug 111445 has been marked as a duplicate of this bug. ***
Comment 9 Telesto 2017-10-09 18:06:39 UTC
*** Bug 112234 has been marked as a duplicate of this bug. ***
Comment 10 Telesto 2017-10-09 18:06:47 UTC
*** Bug 112339 has been marked as a duplicate of this bug. ***
Comment 11 Telesto 2017-10-09 18:06:52 UTC
*** Bug 112361 has been marked as a duplicate of this bug. ***
Comment 12 Telesto 2017-10-09 18:07:00 UTC
*** Bug 112432 has been marked as a duplicate of this bug. ***
Comment 13 Telesto 2017-10-09 18:07:08 UTC
*** Bug 112600 has been marked as a duplicate of this bug. ***
Comment 14 Telesto 2017-10-09 18:07:17 UTC
*** Bug 112899 has been marked as a duplicate of this bug. ***
Comment 15 Alex Thurgood 2017-10-17 08:09:02 UTC
*** Bug 113167 has been marked as a duplicate of this bug. ***
Comment 16 Alex Thurgood 2017-10-17 08:09:35 UTC
*** Bug 111909 has been marked as a duplicate of this bug. ***
Comment 17 Cliff 2017-10-31 18:34:38 UTC
Using HP 451 laser printer every new document I have tried prints in landscape. Just a simple one line document using the default template with modified margins prints as landscape.

Libreoffice 5.3.3. does not exhibit this behavior with the same template.
Comment 18 Alex Thurgood 2017-11-09 12:18:55 UTC
*** Bug 113710 has been marked as a duplicate of this bug. ***
Comment 19 Telesto 2017-11-21 18:26:16 UTC
Marking as dupe (again) of bug 92190
It's fixed on master 
http://dev-builds.libreoffice.org/daily/master/MacOSX-x86_64@49-TDF/current/

and in LibreOffice 5.4.4

*** This bug has been marked as a duplicate of bug 92190 ***