Bug Hunting Session
Bug 111075 - Crash and no set -Image scan
Summary: Crash and no set -Image scan
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.0.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: wantBacktrace
Depends on:
Blocks: Scanning
  Show dependency treegraph
 
Reported: 2017-08-02 05:10 UTC by Pok
Modified: 2018-09-03 14:57 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot1 (64.05 KB, image/png)
2017-08-09 05:35 UTC, Pok
Details
screenshot2 (22.39 KB, image/png)
2017-08-09 05:37 UTC, Pok
Details
screenshot3 (44.08 KB, image/png)
2017-08-09 05:40 UTC, Pok
Details
screenshot4 (50.70 KB, image/png)
2017-08-09 05:44 UTC, Pok
Details
download error? I think it loaded. (99.36 KB, image/png)
2017-09-03 07:10 UTC, Pok
Details
Preview error as usual. (64.31 KB, image/png)
2017-09-03 07:12 UTC, Pok
Details
Blue dots with anchor (25.01 KB, image/png)
2017-09-03 07:14 UTC, Pok
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pok 2017-08-02 05:10:08 UTC
Description:
I was hoping the newer version would fix the scanner problem. It did not. On Ubuntu OS, AMD10, 32gb and HP-OfficeJet-7610-series.  

Writer>Insert>Media>Scan>Select Source>Scan ...Crash.
I switched to 
hpaio:/net/officejet_7610_series?ip=10.0.0.2&queue=false
and got it to scan.
Now I see Six blue dots on the screen but no image. How do I set the image frame?  Click on anchor and nothing. Right click and see Anchor settings.
I have to use Gscan to scan a document.

Steps to Reproduce:
1.WriterInsert>Media>Scan>Select Source>Scan ...Crash.
2.WriterInsert>Media>Scan>Select Source>Preview...nothing
3.Change printer device.  Still no preview, cannot anchor image..cannot see it.

Actual Results:  
1.WriterInsert>Media>Scan>Select Source>Scan ...Crash.
2.WriterInsert>Media>Scan>Select Source>Preview...nothing
3.Change printer device.  Still no preview, cannot anchor image..cannot see it.

Expected Results:
Image on document.


Reproducible: Always

User Profile Reset: No

Additional Info:
Image is on scanner. Gscan2pdf picks it up fine.
I have 6 blue dots but cannot anchor image that is not visible.


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:54.0) Gecko/20100101 Firefox/54.0
Comment 1 Regina Henschel 2017-08-02 08:36:54 UTC
I cannot confirm it for Windows 7 and LO 5.4.
The menu sequence is different here: Writer > Insert >Media > Scan> Select Source. Now there is no option "Scan", but a window pops up with a list of input devices, where I can select my scanner.
Comment 2 Xisco Faulí 2017-08-02 17:45:05 UTC
I can't reproduce it in

Version: 6.0.0.0.alpha0+
Build ID: 50799a721c7ddcf9475a1b79984ed64ddd7cdf57
CPU threads: 4; OS: Linux 4.8; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

with no scanner installed.

Could you please download a debug build from http://dev-builds.libreoffice.org/daily/master/ ( the ones with dbg in the end ) and get a backtrace as explained in here: https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#GNU.2FLinux:_How_to_get_a_backtrace
Comment 3 Pok 2017-08-09 05:35:21 UTC
Created attachment 135333 [details]
screenshot1

I have to go to this menu to select the network printer every time.
Comment 4 Pok 2017-08-09 05:37:59 UTC
Created attachment 135334 [details]
screenshot2

When I have selected the network printer I can then scan the document.
I get the setting dots but no image.
Comment 5 Pok 2017-08-09 05:40:33 UTC
Created attachment 135335 [details]
screenshot3

This is as close as I can get to a bug report.  Cannot find bng file to download in the link provided.  404 error.
Comment 6 Pok 2017-08-09 05:44:41 UTC
Created attachment 135336 [details]
screenshot4

Ubuntu 16.04 LTS and the latest LO Writer.  Could not scan on earlier versions as well.  I can scan using Gscan2PDF Program and Scanner works well.
Comment 7 Regina Henschel 2017-08-09 07:42:06 UTC
Do you use http://hplipopensource.com/hplip-web/index.html ?
Comment 8 Pok 2017-09-03 07:06:23 UTC
Okay, Before driver update no crash, after update no crash.
But still cannot see image. 
Scanner scans as usual but no preview and no image.
No change after driver update.
Comment 9 Pok 2017-09-03 07:10:32 UTC
Created attachment 135980 [details]
download error?  I think it loaded.

After I downloaded I clicked run and it opened up in Gedit then the run bar moved across the screen. Then this error showed up.  I did not edit the file.
Comment 10 Pok 2017-09-03 07:12:01 UTC
Created attachment 135981 [details]
Preview error as usual.

Preview error.
Comment 11 Pok 2017-09-03 07:14:19 UTC
Created attachment 135982 [details]
Blue dots with anchor

Anchor does nothing. double click sends me to the properties menu.
Blue dot frame but no image.
Comment 12 Pok 2017-09-03 07:18:20 UTC
Ubuntu and Office are updated as of the latest to date, before Printer update.
Comment 13 Xisco Faulí 2017-11-13 18:05:11 UTC
Could you please download a debug build from here: http://dev-builds.libreoffice.org/daily/master/ ( the ones with -dbg at the end ), and get a backtrace as explain here: https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#GNU.2FLinux:_How_to_get_a_backtrace ?
Comment 14 QA Administrators 2018-07-31 09:38:34 UTC Comment hidden (obsolete)
Comment 15 QA Administrators 2018-09-03 14:57:10 UTC
Dear Bug Submitter,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INSUFFICIENTDATA due to inactivity and
a lack of information which is needed in order to accurately
reproduce and confirm the problem. We encourage you to retest
your bug against the latest release. If the issue is still
present in the latest stable release, we need the following
information (please ignore any that you've already provided):

a) Provide details of your system including your operating
   system and the latest version of LibreOffice that you have
   confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED
and we will attempt to reproduce the issue. Please do not:

a) respond via email 

b) update the version field in the bug or any of the other details
   on the top section of our bug tracker

Warm Regards,
QA Team

MassPing-NeedInfo-20180903