Download it now!
Bug 111084 - Regression in conditional text - Writer becomes unresponsive
Summary: Regression in conditional text - Writer becomes unresponsive
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.1.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: DirectWrite-Regression
  Show dependency treegraph
 
Reported: 2017-08-02 12:39 UTC by Fabio Melo Pfeifer
Modified: 2017-10-18 13:07 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Document affected by the bug. (14.49 KB, application/vnd.oasis.opendocument.text)
2017-08-02 12:39 UTC, Fabio Melo Pfeifer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fabio Melo Pfeifer 2017-08-02 12:39:43 UTC
Created attachment 135072 [details]
Document affected by the bug.

I use a conditional text in some of my documents to put the number of pages in words (not counting the last page). It used to work like a charm until version 5.2.7.2, but from release 5.3 it stopped working. When I use version 5.3 onwards (tested until 5.4.0.2), every time I scroll the document to the page where the conditional text is, the application freezes. I use Libreoffice x64 for Windows (Windows 10 Pro in my case). My workaround is to downgrade to 5.2.7.2.
I tested also in Linux, and it seems that the linux version is unaffected by this bug.
In order to reproduce the bug, please use the attached document and scroll with the mouse wheel to the page 6.
Comment 1 Fabio Melo Pfeifer 2017-08-02 12:46:40 UTC
Just tested with version 5.4.0.2 x86 for Windows, and it is also affected.
Comment 2 Jacques Guilleron 2017-08-03 10:29:44 UTC
Hi Fabio,

Works for me with
LO 5.3.1.2 Build ID: e80a0e0fd1875e1696614d24c32df0f95f03deb2
Threads CPU : 2; Version de l'OS :Windows 6.1; UI Render : par défaut; Moteur de mise en page : nouveau; Locale : fr-FR (fr_FR); Calc: CL
Doesn’t work with :
LO 5.3.2.2 Build ID: 6cd4f1ef626f15116896b1d8e1398b56da0d0ee1
Threads CPU : 2; Version de l'OS :Windows 6.1; UI Render : par défaut; Moteur de mise en page : nouveau; Locale : fr-FR (fr_FR); Calc: CL
and upper versions.
Comment 3 raal 2017-08-06 11:10:50 UTC
This seems to have begun at the below commit.
Adding Cc: to Khaled Hosny; Could you possibly take a look at this one? Thanks

19490574e42c3180a38d55ccbbf1e3a00802150d is the first bad commit
commit 19490574e42c3180a38d55ccbbf1e3a00802150d
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Tue Mar 7 03:23:53 2017 -0800

    source sha:a51b7a1c3a7e7cf7b0c733e1dec40288278c1884
	
	author	Khaled Hosny <khaledhosny@eglug.org>	2017-03-03 03:15:14 (GMT)
committer	Khaled Hosny <khaledhosny@eglug.org>	2017-03-03 13:22:53 (GMT)
commit	a51b7a1c3a7e7cf7b0c733e1dec40288278c1884 (patch)
tree	6452088195b6c0ad617e7a6b9f97ecc8672d321e
parent	5742868ccf030b2c0f03538d030bd18bd5666bdb (diff)
tdf#103831, tdf#100986: Force using GDI when needed
Comment 4 Fabio Melo Pfeifer 2017-09-19 13:53:13 UTC
Tested again with 5.4.1.2

Tested with Hardware Acceleration enabled and disabled, with OpenGL enabled and disabled, and with anti-aliasing enabled and disabled. Doesn't matter, the bug still there.

Returning to version 5.2.7.2, no bug there.
Comment 5 Xisco Faulí 2017-10-18 11:24:04 UTC
Currently there's no way to enable the DirectWrite from the UI, thus closing as
RESOLVED WORKSFORME
Comment 6 Fabio Melo Pfeifer 2017-10-18 13:07:30 UTC
I don't understand closing this bug, as the bug is still there.
For me it prevents me from upgrading from 5.2, as it makes more recent versions unusable for the documents I use.
It is not resolved, and doesn't work for me.
It means we cannot use conditional text in recent versions.