Bug 111087 - Missing icons in 3D extrusion toolbar dropdowns
Summary: Missing icons in 3D extrusion toolbar dropdowns
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Caolán McNamara
QA Contact:
URL:
Whiteboard: target:6.0.0 target:5.4.1
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2017-08-02 17:19 UTC by Maxim Monastirsky
Modified: 2017-08-08 13:35 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Maxim Monastirsky 2017-08-02 17:19:19 UTC
Steps to reproduce:

1. Tools > Options... > LibreOffice > View, change "Icons in menus" to Show. (Note that the bug can be partially reproduced without this step too.)
2. Open Writer.
3. Draw a shape.
4. Turn on 3D extrusion for this shape (it's the last button on the Drawing toolbar) => At this stage the "3D-Settings" toolbar will show. If not, open it from View > Toolbars menu.
5. Click on one of the dropdown buttons of the "3D-Settings" toolbar (Depth, Direction, Lighting, Surface) => Notice the missing icons in the dropdown menus.

This is a regression in 5.4. The icons were there in 5.3.
Comment 1 Jacques Guilleron 2017-08-03 09:26:28 UTC
Hi Maxim,

I reproduce with
LO 5.4.0.0.alpha0+ Build ID: 3a36cf434fb4a967c9ea767cb7ac5f4da0502a0d
CPU threads: 2; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2017-04-28_06:33:58
Locale: fr-FR (fr_FR); Calc: CL
LO 5.4.0.1 Build ID: 962a9c4e2f56d1dbdd354b1becda28edd471f4f2
Threads CPU : 2; OS : Windows 6.1; UI Render : par défaut; 
Locale : fr-FR (fr_FR); Calc: CL

but not with
LO 5.4.0.0.alpha0+ Build ID: a5c947579253a7f4e784004e18929af5ab22fa28
CPU threads: 2; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2017-03-02_01:57:01
Locale: fr-FR (fr_FR); Calc: CL
LO 5.3.3.2 Build ID: 3d9a8b4b4e538a85e0782bd6c2d430bafe583448
Threads CPU : 2; Version de l'OS :Windows 6.1; UI Render : par défaut; Moteur de mise en page : nouveau; 
Locale : fr-FR (fr_FR); Calc: CL
Comment 2 Xisco Faulí 2017-08-03 11:07:40 UTC
Regression introduced by:

author	Caolán McNamara <caolanm@redhat.com>	2017-04-26 14:55:24 (GMT)
committer	Caolán McNamara <caolanm@redhat.com>	2017-04-27 08:50:48 (GMT)
commit	dd1df645b4fe0d33c640a12d1596f75bd68eb928 (patch)
tree	d60eaa16c4870e8eac607c054bd8c70b226e6d65
parent	f9f045e7830d184497554e0e438cc478fa990eb6 (diff)
remove svx bitmaps from .src files

Bisected with bibisect-linux-64-5.4

Adding Cc: to Caolán McNamara
Comment 3 Caolán McNamara 2017-08-03 14:43:59 UTC
I think the problem is that the icons are foo.bmp not foo.png, the actual code will do the right thing and turn bmp into png if a matching png is there but the generation of the icon-themes trying to strip out unused images won't search for png if bmp is missing so the icons don't get included.

Easiest thing is to change the .bmp names to the pngs they really are and they get found again by a build in postprocess and all is well again
Comment 4 Commit Notification 2017-08-03 14:50:14 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7c8efa0972891b732b57754e809e0448163f2004

Resolves: tdf#111087 change names from bmp to png

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2017-08-08 13:35:03 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=fb786089da572e46f7f3dece2e5876ac70e9e569&h=libreoffice-5-4

Resolves: tdf#111087 change names from bmp to png

It will be available in 5.4.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.