Bug Hunting Session
Bug 111198 - Offline help icons misplaced
Summary: Offline help icons misplaced
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
5.3.5.1 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL: http://nabble.documentfoundation.org/...
Whiteboard:
Keywords: bibisectRequest, notBibisectable, regression
Depends on:
Blocks:
 
Reported: 2017-08-02 20:11 UTC by V Stuart Foote
Modified: 2019-05-15 17:40 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments
clip of open images_tango.zip helpimg present 5342 missing 5352 (52.70 KB, image/png)
2017-08-02 20:25 UTC, V Stuart Foote
Details
clip of open images_galaxy.zip helpimg present 5342 missing 5352 (53.13 KB, image/png)
2017-08-02 20:30 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description V Stuart Foote 2017-08-02 20:11:53 UTC
Regression in the icon support for off-line help. OK at 5.3.4.2, but the res/helpimg links remain in 5.3.5.2 build, but the directory is not present.

http://nabble.documentfoundation.org/help-note-icons-broken-tc4219685.html

Some piece of [1][2] needs additional work in 5.3 branch.  It is correct in 5.4 where the helpimg/media/helpimg 'internal' icon theme is built and bundled.

The move of the helpimg out of ../res/helpimg and into its own helpimg/media/helpimg hit a bump. The zip icon sets in share/config are missing the helpimg directory.

=-ref-=

[1] https://gerrit.libreoffice.org/gitweb?p=core.git&a=search&h=HEAD&st=commit&s=helpimg
[2] https://gerrit.libreoffice.org/#/c/31417/
[3] https://opengrok.libreoffice.org/xref/core/xmlhelp/util/main_transform.xsl?a=true#123
Comment 1 V Stuart Foote 2017-08-02 20:25:00 UTC
Created attachment 135088 [details]
clip of open images_tango.zip helpimg present 5342 missing 5352
Comment 2 V Stuart Foote 2017-08-02 20:30:16 UTC
Created attachment 135089 [details]
clip of open images_galaxy.zip helpimg present 5342 missing 5352

The same for the Galaxy icon set where most icons for offline help are placed, helpimg present through 5.3.4.2 build, missing at 5.3.5.2
Comment 3 V Stuart Foote 2017-08-02 20:35:23 UTC
Guess since it is the off-line help component is documentation rather than installation...
Comment 4 Xisco Faulí 2019-05-15 10:12:52 UTC
Hello V Stuart Foote,
Is this bug still valid in LibreOffice 6.3 master ?
Comment 5 Pedro 2019-05-15 15:35:48 UTC
(In reply to Xisco Faulí from comment #4)
> Hello V Stuart Foote,
> Is this bug still valid in LibreOffice 6.3 master ?

This bug is now irrelevant. LibreOffice no longer (at least since the 6.1 branch) uses the Windows Help system. The Offline help is a local copy of the Online help.
It was not fixed and now it is an obsolete issue.
Comment 6 V Stuart Foote 2019-05-15 17:40:39 UTC
(In reply to Pedro from comment #5)
> 
> This bug is now irrelevant. LibreOffice no longer (at least since the 6.1
> branch) uses the Windows Help system. The Offline help is a local copy of
> the Online help.
> It was not fixed and now it is an obsolete issue.

Sorry Pedro, but as you have once again not read the code--we have never used the Windows help system. Rather an internally provided Writer/Web viewer for the HELP content converted from XML via XSLT. See the bug 97629 meta to unwind what has been done.

At the moment the <ahelp> tagging (likely what you confuse for the Windows Help system) is disconnected--see bug 118148 where essentially we have to reconnect the old XHP links across the UI.

The NEWHELP has moved from that internal rendering of the HELP content, to a javascript enabled content drawn from local URLs and rendered into a modern browser as available on system per user choice. 

And, yes it packages the same help content delivered on line--but it has the same path issues with icons. At the moment a lot of the .SVG icons are not correctly picked up in locally installed NEWHELP.

The issue here though has been resolved, with off-line help installed the images_helpimg.zip is being written and populated with icons still needed by the NEWHELP instance. And the other icon themes no longer create a ../res/helpimg directory.

=> WFM