Bug 111308 - Crash in: rtl_uString_assign
Summary: Crash in: rtl_uString_assign
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha0+
Hardware: All All
: medium critical
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard: target:6.0.0 target:5.4.1 target:5.3.6
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2017-08-03 10:50 UTC by Telesto
Modified: 2017-08-03 22:34 UTC (History)
3 users (show)

See Also:
Crash report or crash signature: ["rtl_uString_assign"]


Attachments
Screencast (1.00 MB, video/avi)
2017-08-03 11:29 UTC, Telesto
Details
gdb backtrace (29.48 KB, text/x-log)
2017-08-03 14:52 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2017-08-03 10:50:47 UTC
This bug was filed from the crash reporting server and is br-493e1481-aaff-4a68-b378-ba219f0bd5d2.
=========================================

1. Open Impress
2. Choose the Alizarin template
3. View -> Slide Master
4. Right Click the first slide -> Open Slide Master Design
5. Click Load
6. Category: Business Correspondence -> Template Modern business
7. Press OK
8. Press OK again -> Crash
Comment 1 Xisco Faulí 2017-08-03 11:16:08 UTC Comment hidden (obsolete)
Comment 2 Telesto 2017-08-03 11:29:46 UTC
Created attachment 135097 [details]
Screencast

Repro with:
Version: 6.0.0.0.alpha0+
Build ID: 18f80da7a689ab962735c0f657497b8f1ed4d606
CPU threads: 4; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-07-28_05:15:48
Locale: nl-NL (nl_NL); Calc: CL

Default - 100 - undo steps.
Comment 3 Regina Henschel 2017-08-03 11:46:18 UTC
Reproducible with the given steps in Version: 6.0.0.0.alpha0+
Build ID: 0163984ce76141665296969118791a9ffbf076eb
CPU threads: 4; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-07-30_23:34:14
Locale: de-DE (de_DE); Calc: group
Comment 4 Xisco Faulí 2017-08-03 13:34:51 UTC
I can reproduce it now. Thanks for the video :-D

Version: 6.0.0.0.alpha0+
Build ID: 3f16306964d5bb81dda3c681bcabbacadf424e7b
CPU threads: 4; OS: Linux 4.8; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

Surprisingly, I can't reproduce it in gtk
Comment 5 Xisco Faulí 2017-08-03 14:52:43 UTC
Created attachment 135102 [details]
gdb backtrace
Comment 6 Xisco Faulí 2017-08-03 15:24:16 UTC
it seems the problem is when clicking on load and no slide design is selected by default. On linux, it's much easier to reproduce it with SAL_USE_VCLPLUGIN=gen
Comment 7 Xisco Faulí 2017-08-03 15:58:58 UTC
I can reproduce it back to 

Version: 5.3.0.0.alpha0+
Build ID: 43e241541eefd21cfc7a8e8f51ef958c2a7ba4d7
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

but I can test it with previous versions due to another crash ( bug 101004 )

Caolán, Do you think this crash is related to bug 101004 as well ?
Comment 8 Commit Notification 2017-08-03 19:00:50 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e325a5442ab350e8eb66458aed98d38ce21aec06

Resolves: tdf#111308 crash after load designs with no design selected

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Caolán McNamara 2017-08-03 19:25:03 UTC
backports of fix to 5-4 and 5-3 in gerrit. "Moderate" business letter looks like a weird typo to me. https://gerrit.libreoffice.org/#/c/40748/ I bet it was supposed to be a Modern serif and Modern sans serif variants
Comment 10 Commit Notification 2017-08-03 22:34:29 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ab3e90e48a7ce8b1ebcee39af56289f625940d69&h=libreoffice-5-4

Resolves: tdf#111308 crash after load designs with no design selected

It will be available in 5.4.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2017-08-03 22:34:37 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2b4ebf00d21f6305966c78f82336f9ac76425804&h=libreoffice-5-3

Resolves: tdf#111308 crash after load designs with no design selected

It will be available in 5.3.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.