Download it now!
Bug 111336 - Introduce an indicator for the baseline at the preview of special characters
Summary: Introduce an indicator for the baseline at the preview of special characters
Status: RESOLVED DUPLICATE of bug 90848
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Special-Character
  Show dependency treegraph
 
Reported: 2017-08-04 10:42 UTC by Heiko Tietze
Modified: 2017-12-28 14:38 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Heiko Tietze 2017-08-04 10:42:22 UTC
The identification of a letter would be improved when its baseline is perfectly clear. The small g looks similar to 9, depending on font, or compare COPTIC CAPITAL LETTER FEI Ϥ with COPTIC SMALL LETTER FEI ϥ. Showing the baseline in the preview would be beneficial for clear identification.
Comment 1 V Stuart Foote 2017-08-04 14:07:58 UTC
Any implementation would have challenges--font would have to be parsed for its base line and positioned accordingly. Believe we currently just scale the font and center based on the fonts metric.

The baseline would need to be unobtrusive. And guess while parsing for baseline, could also determine width/ascender/descender/leading and show those as well. The dialog would need a toggle for any of these as in truth the majority of users do not need any of the hinting to recognize the character--including showing the baseline.
Comment 2 V Stuart Foote 2017-12-28 14:38:01 UTC

*** This bug has been marked as a duplicate of bug 90848 ***