Bug Hunting Session
Bug 111339 - Blocks middle mouse Key under GNU/Linux
Summary: Blocks middle mouse Key under GNU/Linux
Status: RESOLVED DUPLICATE of bug 110988
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.4.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-08-04 12:57 UTC by Paul Menzel
Modified: 2017-08-04 13:53 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Menzel 2017-08-04 12:57:25 UTC
Copy the report from bug #62047 [1].

(In reply to haenig from comment #8)
> the bug is back again in LibreOffice 5.4.0.1
> 
> OS is openSuSE Tumbleweed 64bit with XFCE
> thomas@thomas:~> rpm -qi libreoffice
> Name        : libreoffice
> Version     : 5.4.0.1
> Release     : 1.2
> Architecture: x86_64
> 
> what
> works: mark with left mouse key in LibreOffice  -> insert in other program
> with middle mouse key
> works not: mark with left mouse key in other program -> than paste in
> LibreOffice with middle mouse key
> works not: mark with left mouse key in LibreOffice -> paste in LibreOffice
> with middle mouse key
> works: mark with left mouse key in other program -> insert in other program
> with middle mouse key
> 
> therefore the behaviour is identically to what the thread starter wrote.
> 
> the bug was _NOT_ present in LibreOffice 5.0.6.3 as well as in some 4.x
> Versions (used/checked with openSuSE 13.2 with XFCE too)

I am able to reproduce this with a self-built LibreOffice 5.4.0.3 as well. The option Tools -> Options -> LibreOffice -> View -> "Middle Mouse Button" is set correctly to *Paste Clipboard*.

[1] https://bugs.documentfoundation.org/show_bug.cgi?id=62047
Comment 1 Julien Nabet 2017-08-04 13:35:50 UTC
Please don't create a bug just to indicate that an already declared bug exists too in a specific version.

*** This bug has been marked as a duplicate of bug 62047 ***
Comment 2 Paul Menzel 2017-08-04 13:50:23 UTC
(In reply to Julien Nabet from comment #1)
> Please don't create a bug just to indicate that an already declared bug
> exists too in a specific version.
> 
> *** This bug has been marked as a duplicate of bug 62047 ***

Julien, please read the report. @haenig reports it did work with 5.0.6.3. There are several bug reports out there, where the developer ask to create a new issue for new problems, as it’s unlikely it’s the same problem.

But you seem to be involved in LibreOffice, so do as you wish with the information.
Comment 3 Aron Budea 2017-08-04 13:53:24 UTC
Redirecting this to be duplicate of the regression.

*** This bug has been marked as a duplicate of bug 110988 ***