Bug 111347 - crash when pasting from HTML
Summary: crash when pasting from HTML
Status: RESOLVED DUPLICATE of bug 112180
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-08-04 15:26 UTC by Robert McClure
Modified: 2017-09-15 16:04 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot (422.68 KB, image/png)
2017-08-08 02:30 UTC, halima
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert McClure 2017-08-04 15:26:23 UTC
Copying a mixed page of HTML and pasting into a Writer page frequently causes a crash. This happens whether or not there is anything previously on the Writer page. It is more frequent when there are both images and text, but it also happens occasionally when there is nothing but text.

Version: 5.4.0.3 (x64)
Windows 7 Ultimate, Service Pack 1
AMD FX 6100 3.3 processor
16GB memory
Comment 1 raal 2017-08-04 15:59:48 UTC
Hello,
Thank you for reporting the bug. Unfortunately without clear steps to reproduce it, we cannot track down the origin of the problem. Please provide a clearer set of step-by-step instructions on how to reproduce the problem. Write www page and parts of page to copy.
Comment 2 Robert McClure 2017-08-04 17:50:35 UTC
go to
https://pjmedia.com/trending/2017/08/03/why-cnns-jim-acosta-is-wrong-about-the-statue-of-liberty/

click the print button to get the printable page loaded.
This will bring up a print panel, so click "cancel".
The select the page from the leading word "Why" through the end of the
main article to the word "yesterday"

press control-C to copy the selection

bring up Writer with a blank page.
press control-V to paste.

The page first appears, and the the error message "allocation error"

Bring up Writer again and you get the recovery panel. Click recover and when this is done click "finish" -- Now you have a blank page again.

That's it for simplicity.
Comment 3 Xisco Faulí 2017-08-06 20:17:51 UTC
(In reply to Robert McClure from comment #2)
> go to
> https://pjmedia.com/trending/2017/08/03/why-cnns-jim-acosta-is-wrong-about-
> the-statue-of-liberty/
> 
> click the print button to get the printable page loaded.
> This will bring up a print panel, so click "cancel".
> The select the page from the leading word "Why" through the end of the
> main article to the word "yesterday"

Which browser are you using? In chrome, it doesn't get selected after cancelling. 
> 
> press control-C to copy the selection
> 
> bring up Writer with a blank page.
> press control-V to paste.
> 
> The page first appears, and the the error message "allocation error"
> 
> Bring up Writer again and you get the recovery panel. Click recover and when
> this is done click "finish" -- Now you have a blank page again.
> 
> That's it for simplicity.

Selecting it manually, I can't reproduce it in

Version: 6.0.0.0.alpha0+
Build ID: 1e87e93132f808ab95eab932b36bfe40d3cc607a
CPU threads: 1; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2017-07-25_06:09:29
Locale: es-ES (es_ES); Calc: group

Please provide a clearer set of step-by-step instructions on how to reproduce the problem.
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the steps are provided
Comment 4 Robert McClure 2017-08-06 21:09:36 UTC
The browser is Firefox 54.0.1 (32bit)

Go to almost any page that has both text and images.

Select about a page and a half of mixed text and images.

Control C

Open Writer

Control V

That's all you have to do. Tried moments ago with
these:

Wall Street Journal     wsj.com
Drudge Report     drudgereport.com
Pajamas Media     pjmedic.com
Comment 5 Xisco Faulí 2017-08-06 21:35:04 UTC
To be certain the reported issue is not related to corruption in the user profile, could you please reset your Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and re-test?

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the issue is still present
Comment 6 Robert McClure 2017-08-07 02:33:17 UTC
Resetting the preferences does NOT change the behavior.
Comment 7 Xisco Faulí 2017-08-07 16:31:51 UTC
Does it crash for you if you use Ctrl+A to select the whole page? In other way it would crash instead of using the print option? In my case, text doesn't get selected after closing the dialog.
Comment 8 Robert McClure 2017-08-07 16:40:23 UTC
Here is a very simple test that causes a crash for me.
Go to    www.laralaneaz.com    (I own that page and it will not change.)
select from   "There is plenty" through the end of the page  "(office)"

Control C  (to copy that to the clipboard)

Bring up Writer and a blank page.

Control V (to paste that to Writer)

Here that causes a crash.

I have tried the same with Opera and get the same crash.

If only text, or only the bottom banner is selected, I do not get a crash. Only when both are selected at the same time.

I can paste this to a program called "Textmaker" which I think is German and do not get a crash.  I can paste this to notepad or vim and do not get a crash.
Comment 9 Xisco Faulí 2017-08-07 18:42:05 UTC
Thanks for the detailed steps.
However, I can't reproduce it in

Versión: 5.4.0.3
Id. de compilación: 7556cbc6811c9d992f4064ab9287069087d7f62c
Subproc. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; 
Configuración regional: es-ES (es_ES); Calc: group

is OpenGL enabled?
Comment 10 Robert McClure 2017-08-07 19:04:38 UTC
OpenGL was enable, but switching it off and restarting Libreoffice does not change the behavior. It still(sob) crashes.
Comment 11 Telesto 2017-08-07 19:31:07 UTC
No repro with
Version: 6.0.0.0.alpha0+
Build ID: 386fcf9be786b302cd2c6f85ff6d8d97a6777926
CPU threads: 4; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-08-06_01:57:50
Locale: nl-NL (nl_NL); Calc: CL

nor with:
Version: 5.4.0.3

@Robert McClure 
A long shot (based on bug 109253)
Does LibreOffice crash when Scroll through the list of fonts?
1. Open Writer
2. Scroll through the list of fonts
Comment 12 Robert McClure 2017-08-07 20:32:09 UTC
Yes, scrolling through the font list causes a crash. Interestingly enough you can drag the slider down to where you need a font without a problem, but scrolling with either the scroll buttons, or by clicking in the bar, may (but not always) provoke a crash. If I start at the top of a fairly long list of fonts, it usually gets about half way through before crashing.
Comment 13 halima 2017-08-08 02:30:01 UTC
Created attachment 135257 [details]
screenshot
Comment 14 halima 2017-08-08 02:44:43 UTC
No problem faced for posting mixed page of HTML in Writer page
with :
Windows 10 x64
LO Version: 5.3.5.2
Build ID: 50d9bf2b0a79cdb85a3814b592608037a682059d
Threads CPU : 4; OS : Windows 6.2; UI Render : GL; Layout Engine: new; 
Firefox 54.0.1 (32bit)
Comment 15 Telesto 2017-08-08 07:04:20 UTC
Moving to bug 109253 based on comment 12

*** This bug has been marked as a duplicate of bug 109253 ***
Comment 16 V Stuart Foote 2017-09-15 16:04:58 UTC

*** This bug has been marked as a duplicate of bug 112180 ***