Bug Hunting Session
Bug 111394 - Bad export from Draw to SVG-format - not similar export to PNG-format
Summary: Bad export from Draw to SVG-format - not similar export to PNG-format
Status: RESOLVED DUPLICATE of bug 111806
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
5.4.0.3 release
Hardware: x86-64 (AMD64) Linux (All)
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks: SVG-Save
  Show dependency treegraph
 
Reported: 2017-08-05 10:54 UTC by Nick222
Modified: 2018-01-07 09:16 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Source picture (7.70 KB, application/vnd.oasis.opendocument.graphics)
2017-08-05 10:55 UTC, Nick222
Details
Result export to PNG (8.63 KB, image/png)
2017-08-05 10:55 UTC, Nick222
Details
Result export to SVG (4.58 KB, image/svg+xml)
2017-08-05 10:56 UTC, Nick222
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nick222 2017-08-05 10:54:00 UTC
Description:
Xubuntu 17.04-64
LibreOffice Версия: 5.4.0.3 ID сборки: 1:5.4.0~rc3-0ubuntu0.17.04.1~lo0 Потоков ЦП: 4; ОС:Linux 4.10; Отрисовка ИП: по умолчанию; VCL: gtk3; Локаль: ru-RU (ru_RU.UTF-8); Calc: group
install from http://ppa.launchpad.net/libreoffice/ppa/ubuntu

Steps to Reproduce:
1. Start LibreOffice Draw
2. Create simple picture
3. Export it to PNG-format
4. Export it to SVG-format

Actual Results:  
After export from same ODG-file PNG and SVG files visual different

Expected Results:
I think PNG and SVG files must be the same


Reproducible: Always

User Profile Reset: Yes. I uninstall LibreOffice at all (uninstall with config - in options Synaptic), then manually delete user profile and then install LibreOffice again.

Additional Info:


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:54.0) Gecko/20100101 Firefox/54.0
Comment 1 Nick222 2017-08-05 10:55:03 UTC
Created attachment 135166 [details]
Source picture
Comment 2 Nick222 2017-08-05 10:55:45 UTC
Created attachment 135167 [details]
Result export to PNG
Comment 3 Nick222 2017-08-05 10:56:12 UTC
Created attachment 135168 [details]
Result export to SVG
Comment 4 V Stuart Foote 2017-08-05 12:33:14 UTC
Can not reproduce on Widnows build. Export to SVG mataches export to PNG and to PDF, no corruption of image.

On Windows 10 Home 64-bit en-US with
Version: 5.4.0.3 (x64)
Build ID: 92c2794a7c181ba4c1c5053618179937228ed1fb
CPU threads: 4; OS: Windows 6.19; UI render: default; 
Locale: en-US (en_US); Calc: group
Comment 5 Nick222 2017-08-05 13:59:03 UTC
I know - it is only Linux-version bug, I think...
Comment 6 ape-2 2017-08-06 02:09:43 UTC
 I confirm the export error in SVG for OS Linux.

lubuntu-16.04 LTS:

ID сборки: 7556cbc6811c9d992f4064ab9287069087d7f62c
Потоков ЦП: 4; ОС:Linux 4.4; Отрисовка ИП: по умолчанию; VCL: gtk2; 
Локаль: ru-RU (ru_RU.UTF-8); Calc: group

@ V Stuart Foote: OK in OSX and Windows (XP - 10)
Comment 7 Buovjaga 2017-08-07 13:39:58 UTC
Tonygaga on IRC confirmed that this worked in 5.3.
This is Linux-only: he tested on Windows and Linux.
Comment 8 raal 2017-08-09 18:36:38 UTC
no repro Version: 6.0.0.0.alpha0+
Build ID: e0bafa78e3ad0df397d78cd65ad19bd5b07dc5f2
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-07-20_22:42:49
Comment 9 Buovjaga 2017-08-09 18:47:28 UTC
(In reply to raal from comment #8)
> no repro Version: 6.0.0.0.alpha0+
> Build ID: e0bafa78e3ad0df397d78cd65ad19bd5b07dc5f2
> CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk2; 
> TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time:
> 2017-07-20_22:42:49

Yep, I cannot repro on master, but do repro on 5.4.
So I wonder, if we should bother bibisecting.

Arch Linux 64-bit, KDE Plasma 5
Version: 6.0.0.0.alpha0+
Build ID: 7915f35d7fca5d0720d96954beaa97c00a2c3821
CPU threads: 8; OS: Linux 4.12; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on August 7th 2017

Arch Linux 64-bit, KDE Plasma 5
Version: 5.4.0.3
Build ID: 5.4.0-1
CPU threads: 8; OS: Linux 4.12; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Comment 10 Kai Struck 2018-01-04 18:39:55 UTC
Perhaps related:
https://bugs.documentfoundation.org/show_bug.cgi?id=111806
Comment 11 Razor T 2018-01-07 06:26:49 UTC
Yes, I think it's the same bug. Look there for a detailed
 description of the problem and a solution.
Comment 12 raal 2018-01-07 09:16:51 UTC
(In reply to Razor T from comment #11)
> Yes, I think it's the same bug. Look there for a detailed
>  description of the problem and a solution.

Razor T did an analyze in bug 111806

*** This bug has been marked as a duplicate of bug 111806 ***