Bug 111425 - Crash in: mergedlo.dll
Summary: Crash in: mergedlo.dll
Status: RESOLVED DUPLICATE of bug 108299
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.4.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-08-06 22:33 UTC by Stefan_Lange_KA@T-Online.de
Modified: 2017-08-08 08:05 UTC (History)
1 user (show)

See Also:
Crash report or crash signature: ["mergedlo.dll"]


Attachments
Screenshot when error report was sended (no report ID, but "Error!") (48.94 KB, image/jpeg)
2017-08-07 19:24 UTC, Stefan_Lange_KA@T-Online.de
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan_Lange_KA@T-Online.de 2017-08-06 22:33:53 UTC
This bug was filed from the crash reporting server and is br-5e253434-c372-4590-a08e-edf3cbf1d15e.
=========================================
The problem is nearly like in Bug 105055, but the circumstances are little bit others.
In special cases shutdown of LibreOffice (LO) is not completed. In the Task Manager remain 2 LO processes. When one then tries to start LO again (one time or repeatedly), it seems that LO doesn't start, but in the Task Manager appear 4 or more LO processes, belonging pairwise one to another. Only when the "old" processes are cancelled in the Task Manager, LO really opens.
Then it says (only in LO 5.4.0, not in LO 6.0.0.0.alpha0+ (x64)): "Leider scheint LibreOffice bei der letzten Verwendung abgestürzt zu sein." (Unfortunately LibreOffice seems to have crashed during the last use.). 

Steps to reproduce the behavior:
- open the attached spreadsheet "Testtabelle_Abbruch_Copy_Paste.ods" (from Bug 104967)

- go to sheet "Altix IV und V"
- copy line 7 and paste it into line 13
or
- go to sheet "Kameras"
- copy line 12 and paste it into line 20

(both copied lines have cells with comments)

- save the document or not and close LO
--> Shutdwon of LO hangs: LO Windows is closed, but in the task manager remain 2 LibreOffice processes and hinder a new start of LO

Also reproduced with 
Version: 6.0.0.0.alpha0+ (x64)
Build ID: 386fcf9be786b302cd2c6f85ff6d8d97a6777926
CPU threads: 4; OS: Windows 6.19; UIrender: GL;
TinderBox: Win-x86_64@42, Branch:master, Time: 2017-08-06_03::08:58
Locale: de-DE (de_DE); Calc: CL

not reproduced with LO 5.3.5 x64 release
Comment 1 Telesto 2017-08-07 12:02:34 UTC
Repro only with OpenGL enabled with:
Version: 6.0.0.0.alpha0+
Build ID: 386fcf9be786b302cd2c6f85ff6d8d97a6777926
CPU threads: 4; OS: Windows 6.19; UI render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-08-06_01:57:50
Locale: nl-NL (nl_NL); Calc: CL

It has a lot in common with bug 108299
Comment 2 Xisco Faulí 2017-08-07 16:28:39 UTC
(In reply to Telesto from comment #1)
> Repro only with OpenGL enabled with:
> Version: 6.0.0.0.alpha0+
> Build ID: 386fcf9be786b302cd2c6f85ff6d8d97a6777926
> CPU threads: 4; OS: Windows 6.19; UI render: GL; 
> TinderBox: Win-x86@42, Branch:master, Time: 2017-08-06_01:57:50
> Locale: nl-NL (nl_NL); Calc: CL
> 
> It has a lot in common with bug 108299

@Telesto, could you please try to reproduce in LibreOffice 5.3.X? This way we'll know if the signature is the same...
Comment 3 Stefan_Lange_KA@T-Online.de 2017-08-07 17:09:53 UTC
Because of  Comment 1 I have repeated my tests with and without activated OpenGL:
LO 5.4.0:
- OpenGL activated -> described behaviior
- OpenGL not activated -> no problems, no LO tasks remain in Task Manager after LO  is closed
LO 5.3.5.2: no problems, even if OpenGL is activated or not
Comment 4 Stefan_Lange_KA@T-Online.de 2017-08-07 19:24:36 UTC
Created attachment 135233 [details]
Screenshot when error report was sended (no report ID, but "Error!")

Addition:
Test with
Version: 5.3.6.0.0+ (x64)
Build-ID: 8cfb5788cc602e0a81ae47832c65cf2402471034
CPU-Threads: 4; BS-Version: Windows 6.19; UI-Render: GL; Layout-Engine: neu; 
TinderBox: Win-x86_64@62-TDF, Branch:libreoffice-5-3, Time: 2017-07-31_21:50:11
Gebietsschema: de-DE (de_DE); Calc: CL

OenGL not activated -> no problems
OpenGL activated -> behavior as described in the bug

After I have killed the LO tasks in the Task Manager, at the start of LO appeared the error message and the question if an error report should be sended. I have confirmed this, but instead a report ID I got only "Error!" (tried 2 times, same result). So I don't if the reports were sended or not.
Comment 5 Xisco Faulí 2017-08-08 07:45:24 UTC
I think the error issue is related to bug 109347 and it should be fixed in 5.4.1
Comment 6 Timur 2017-08-08 08:05:43 UTC
Let's close as duplicate of Bug 108299 and track that one that has 12490 reports!

*** This bug has been marked as a duplicate of bug 108299 ***