Bug 111489 - VIEWING: Text become blurred while zooming
Summary: VIEWING: Text become blurred while zooming
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Armin Le Grand
URL:
Whiteboard:
Keywords: bibisected, regression
: 111491 111495 111496 (view as bug list)
Depends on:
Blocks: Regressions-EMFPlus-Rework
  Show dependency treegraph
 
Reported: 2017-08-08 11:21 UTC by Xisco Faulí
Modified: 2017-08-31 22:45 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
sample (83.00 KB, application/msword)
2017-08-08 11:21 UTC, Xisco Faulí
Details
Comparison LibreOffice 5.4 and LibreOffice 6.0 (353.02 KB, image/png)
2017-08-08 11:23 UTC, Xisco Faulí
Details
sample2 (34.50 KB, application/msword)
2017-08-08 11:37 UTC, Xisco Faulí
Details
Comparison of sample2 (34.50 KB, application/msword)
2017-08-08 11:37 UTC, Xisco Faulí
Details
sample3 (deleted)
2017-08-08 11:44 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2017-08-08 11:21:47 UTC
Created attachment 135269 [details]
sample

Steps to reproduce:
1. Open attached document
2. Zoom it up to 300%

Observed behaviour: Text is more blur than in previous versions. See the image attached

Versió: 6.0.0.0.alpha0+
ID de la construcció: 0342c5e8086c8200ecadbe9d52dd4ef6a093effb
CPU threads: 4; OS: Linux 4.10; UI render: per defecte; VCL: gtk3; 
Configuració local: ca-ES (ca_ES.UTF-8); Calc: group

[Bug found by office-interoperability-tools]
Comment 2 Xisco Faulí 2017-08-08 11:23:52 UTC
Created attachment 135270 [details]
Comparison LibreOffice 5.4 and LibreOffice 6.0
Comment 3 Xisco Faulí 2017-08-08 11:37:12 UTC
Created attachment 135277 [details]
sample2

Another file affected by the same problem
Comment 4 Xisco Faulí 2017-08-08 11:37:44 UTC
Created attachment 135279 [details]
Comparison of sample2
Comment 5 Xisco Faulí 2017-08-08 11:44:02 UTC Comment hidden (obsolete)
Comment 6 Xisco Faulí 2017-08-08 11:51:14 UTC Comment hidden (obsolete)
Comment 7 Armin Le Grand 2017-08-21 17:12:29 UTC
It is a PDF in a MS-Word doc, gets read by us as Metafile. This has 5 actions, containing the graphic stuff as single Bitmap. With the Bitmap now embedded as primitive, it gets painted by the system renderers. Also before this should have happened, but maybe this was still painted using the old vcl self-scaling. In fist case, AA is the sdame, in the 2nd it will be better. Checked with LO52 - for me it looks quite the same, slightly better. Also the Zoom/scroll will now be much better. More an enhancement.
Comment 8 Armin Le Grand 2017-08-22 07:37:32 UTC
Checked and as I thought, problem is writer is not using primitives (yet) to paint that content, this needs to be enhanced.
Comment 9 Armin Le Grand 2017-08-22 08:02:10 UTC
Have adapted to let writer use primitive rendering. This is the prerequisite to use the VectorData available. For now, this will fallback to VclProcessor2D::RenderMetafilePrimitive2D and thus use the direct renderer again wich we try to get rid of, but this is needed for fallback quality to the current state of things, so slowlyness and speed/hang/crash on zoom will be back for a (hopefully short) while. I checked that all this is much better with the fully activated emfplus stuff.
All tasks have this same reason, so all others are double to this one.
Comment 10 Armin Le Grand 2017-08-22 08:02:53 UTC
*** Bug 111491 has been marked as a duplicate of this bug. ***
Comment 11 Armin Le Grand 2017-08-22 08:03:05 UTC
*** Bug 111495 has been marked as a duplicate of this bug. ***
Comment 12 Armin Le Grand 2017-08-22 08:03:15 UTC
*** Bug 111496 has been marked as a duplicate of this bug. ***
Comment 13 Armin Le Grand 2017-08-22 13:22:47 UTC
fix done and in master, building locally to do a 2nd check
Comment 14 Armin Le Grand 2017-08-22 14:59:37 UTC
Allright, now we have this ficed and the EMF+ activated - all much faster and better quality. Faster in EditView (zoom, panning) and faster and much better quality in e.g. PDF export.
Comment 15 Xisco Faulí 2017-08-31 22:45:09 UTC
Verified in

Version: 6.0.0.0.alpha0+
Build ID: 04d70c0999c716f5465631eca50945915ec607c4
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group