Bug 111495 - FILEOPEN: Incorrect image colours in ole objects
Summary: FILEOPEN: Incorrect image colours in ole objects
Status: RESOLVED DUPLICATE of bug 111489
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, regression
Depends on:
Blocks: Regressions-EMFPlus-Rework
  Show dependency treegraph
 
Reported: 2017-08-08 11:57 UTC by Xisco Faulí
Modified: 2017-08-22 08:03 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
sample1 (108.50 KB, application/msword)
2017-08-08 11:57 UTC, Xisco Faulí
Details
sample2 (39.50 KB, application/msword)
2017-08-08 11:58 UTC, Xisco Faulí
Details
sample3 (181.50 KB, application/msword)
2017-08-08 12:12 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2017-08-08 11:57:18 UTC
Created attachment 135282 [details]
sample1

Similar to bug 111489 but without zooming.

Steps to reproduce:
1. open Attached document

Observed behaviour: Image in ole object are blurred

Reprocuced in

Versió: 6.0.0.0.alpha0+
ID de la construcció: 0342c5e8086c8200ecadbe9d52dd4ef6a093effb
CPU threads: 4; OS: Linux 4.10; UI render: per defecte; VCL: gtk3; 
Configuració local: ca-ES (ca_ES.UTF-8); Calc: group

[Bug found by office-interoperability-tools]
Comment 2 Xisco Faulí 2017-08-08 11:58:21 UTC
Created attachment 135283 [details]
sample2
Comment 3 Xisco Faulí 2017-08-08 12:12:45 UTC
Created attachment 135285 [details]
sample3

Another file affected. In this one, it's quite easy to see the issue
Comment 4 Armin Le Grand 2017-08-21 17:23:52 UTC
Need to check that one, maybe the replacement graphic gets painted. Btw, again much faster and old version crashes/hangs when zooming in.
Comment 5 raal 2017-08-21 20:38:26 UTC
Confirm. win7,LO 6.
Comment 6 Armin Le Grand 2017-08-22 08:03:05 UTC

*** This bug has been marked as a duplicate of bug 111489 ***