Bug Hunting Session
Bug 111546 - [LOCALIZATION] Untranslatable string in context menu
Summary: [LOCALIZATION] Untranslatable string in context menu
Status: RESOLVED DUPLICATE of bug 95489
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Not-Localizable
  Show dependency treegraph
 
Reported: 2017-08-09 00:45 UTC by Olivier Hallot
Modified: 2017-12-02 07:48 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Image of the unstranslatable menu entry "Quotation" (49.90 KB, image/png)
2017-08-09 00:45 UTC, Olivier Hallot
Details
Has KeyID in 6.1 master (83.16 KB, image/png)
2017-12-01 20:21 UTC, Gabor Kelemen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier Hallot 2017-08-09 00:45:56 UTC
Created attachment 135327 [details]
Image of the unstranslatable menu entry "Quotation"

In writer, select text e open context menu.

In Styles, the entry "Quotation" is not translatable.

see image attached.
Comment 1 Jean-Baptiste Faure 2017-08-09 09:26:32 UTC
Something to do with bug 108752 ?

Best regards. JBF
Comment 2 Gabor Kelemen 2017-08-09 11:37:28 UTC
Probably the same translation mistake as in bug #81465.
Comment 3 Olivier Hallot 2017-08-09 12:15:06 UTC
Yes but the fact that there is no KeyID (in the image) is a symptom of a possible problem when bringing the string to Pootle.
Comment 4 Jean-Baptiste Faure 2017-08-10 04:49:07 UTC
I confirm that the Quotation style does not have a keyID in current master and that is clearly a bug (why this one and not the others?). So setting as NEW.

q8p26‖Version: 6.0.0.0.alpha0+
XZmEs‖Build ID: c9b60d8884c125482959e3514cf14e60bfc86ba9
Dk4vc‖CPU threads: 4; 5DyEd‖OS: Linux 4.4; Yqrwo‖UI render: ZitRE‖default; VCL: gtk3; 
Ubuntu_16.04_x86-64
Ru2AA‖Locale: fr-FR (fr_FR.UTF-8); Calc: single

Best regards. JBF
Comment 5 Adolfo Jayme 2017-08-13 22:48:54 UTC
Please try again in 5.4.1 RC1, which includes https://cgit.freedesktop.org/libreoffice/core/commit/?id=9ab228fdd6efe9a7873e3de1bb2357531a79feac&h=libreoffice-5-4
Comment 6 Jean-Baptiste Faure 2017-08-14 17:41:19 UTC
(In reply to Adolfo Jayme from comment #5)
> Please try again in 5.4.1 RC1, which includes
> https://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=9ab228fdd6efe9a7873e3de1bb2357531a79feac&h=libreoffice-5-4

As far I know, there is no key-ID in RC.

Best regards. JBF
Comment 7 Martin Srebotnjak 2017-12-01 10:01:30 UTC
Cannot confirm in 60b1, actually it is localized in Slovenian.

So I should select worksforme?
Comment 8 Gabor Kelemen 2017-12-01 20:21:53 UTC
Created attachment 138173 [details]
Has KeyID in 6.1 master

q8p26‖Version: 6.1.0.0.alpha0+
XZmEs‖Build ID: b15f79a8f8de27c9d186ae1fbd0c86f194aed0ac
Dk4vc‖CPU threads: 4; 5DyEd‖OS: Linux 4.4; Yqrwo‖UI render: 8YjVN‖GL; VCL: gtk2; 
Ru2AA‖Locale: hu-HU (hu_HU.UTF-8); Calc: group threaded
Comment 9 Gabor Kelemen 2017-12-01 20:27:45 UTC
Also present in Pootle for master branch: https://translations.documentfoundation.org/hu/libo_ui/translate/#search=gvtib&sfields=notes
Comment 10 Jean-Baptiste Faure 2017-12-02 07:20:58 UTC
(In reply to Gabor Kelemen from comment #8)
> Created attachment 138173 [details]
> Has KeyID in 6.1 master

In 6.0 branch too.

Best regards. JBF
Comment 11 Yousuf Philips (jay) (retired) 2017-12-02 07:48:07 UTC

*** This bug has been marked as a duplicate of bug 95489 ***