Download it now!
Bug 111624 - Text is no printed from Calc spreadsheets
Summary: Text is no printed from Calc spreadsheets
Status: RESOLVED DUPLICATE of bug 109281
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.4.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-08-10 07:31 UTC by andreis.oscar
Modified: 2017-08-10 09:12 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
A simple test file (8.74 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-08-10 07:34 UTC, andreis.oscar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description andreis.oscar 2017-08-10 07:31:18 UTC
Description:
Start from LibreOffice 5.4 (previous versions work properly) I'm unable to print text inside spreadsheets: the printer prints only cells borders and backgrounds, without characters.
The issue is also displayed using PDFCreator instead of a real printer.

Steps to Reproduce:
1.Open an empty spreadsheet
2.Set some cell's borders and backgrounds
3.Write some text (tried with different fonts eg. Arial, Liberation Sans)
4.Print


Actual Results:  
The printer prints only cells borders and backgrounds, without characters.

Expected Results:
Print all the text.


Reproducible: Always

User Profile Reset: No

Additional Info:
"PDF export" toolbar button work properly.


User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:54.0) Gecko/20100101 Firefox/54.0
Comment 1 andreis.oscar 2017-08-10 07:34:26 UTC
Created attachment 135396 [details]
A simple test file
Comment 2 m.a.riosv 2017-08-10 08:22:17 UTC
Works for me.

Please test with Menu/Help/Restart in Safe Mode
Comment 3 Timur 2017-08-10 08:53:39 UTC
Andreis, first thank you for nicely explained bug. 
What I guess is that you have 5.4.0.3 before fix that included Bug 109281 and Bug 107166. 
https://wiki.documentfoundation.org/ReleasePlan/5.4#5.4.0_release doesn't mention fix but bugs are there. 
Looks like a bug of Bug 109281. 
Reproduced in 5.4.0.3 before fix, not reproduced in master 6.0+.

My advise is to test with master before reporting. 
I recommend using Separate Install GUI tool from https://flosmind.wordpress.com/si-gui/ which downloads and extracts different LO versions up to the current master, without installing.

*** This bug has been marked as a duplicate of bug 109281 ***
Comment 4 andreis.oscar 2017-08-10 09:12:11 UTC
Thanks, I had a bad 5.4.0.3 version. Uninstalling it and installing the "latest" 5.4.0.3 the problem is SOLVED.