Bug Hunting Session
Bug 111679 - DOCX Import - tables converted to text
Summary: DOCX Import - tables converted to text
Status: RESOLVED DUPLICATE of bug 116194
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
4.3.7.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX-Tables
  Show dependency treegraph
 
Reported: 2017-08-11 03:29 UTC by Paul
Modified: 2019-01-10 09:37 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Source DocX File when loaded into Writer tables are lost (16.82 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-08-11 03:31 UTC, Paul
Details
Screen shot showing the problem (Word vs Writer) (5.73 KB, image/png)
2017-08-11 03:32 UTC, Paul
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Paul 2017-08-11 03:29:52 UTC
Description:
The attached DocX file has two trivial tables.  When loaded into Writer the tables are lost and converted into text.  The attached screen shot shows how the document looks in Word vs Writer.

Steps to Reproduce:
1. Open DOCX file in Writer

Actual Results:  
The 2 tables were converted into paragraphs of text.

Expected Results:
The 2 tables should be imported as tables.


Reproducible: Always

User Profile Reset: Yes

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:55.0) Gecko/20100101 Firefox/55.0
Comment 1 Paul 2017-08-11 03:31:22 UTC
Created attachment 135443 [details]
Source DocX File when loaded into Writer tables are lost
Comment 2 Paul 2017-08-11 03:32:23 UTC
Created attachment 135444 [details]
Screen shot showing the problem (Word vs Writer)
Comment 3 Julien Nabet 2017-08-11 07:54:20 UTC
4.X LO versions are EOL, idem for 5.0.X, 5.1.X and 5.2.X
Could you give a try to a recent LO version? (last stable one is 5.3.5)
Comment 4 Julien Nabet 2017-08-11 07:55:46 UTC
Forget my previous comment, I could reproduce this on Win7 with LO 5.3.4
Comment 5 Paul 2017-08-11 10:59:55 UTC
Yes, I tested on various 4 and 5 versions up to the current still (5.3.5) and fresh (5.4.0) versions and they too have the problem.
Comment 6 QA Administrators 2018-10-23 02:48:47 UTC Comment hidden (obsolete)
Comment 7 Roman Kuznetsov 2018-10-23 07:14:26 UTC
still repro in

Version: 6.2.0.0.alpha0+
Build ID: cec31fdedd7c94f4ebf903a66456a75867db22b0
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-10-21_22:54:44
Locale: ru-RU (ru_RU); Calc: threaded
Comment 8 Timur 2019-01-10 09:37:37 UTC

*** This bug has been marked as a duplicate of bug 116194 ***