Bug Hunting Session
Bug 111707 - EDITING: No Remove Hyperlink option (in context menu) in Impress
Summary: EDITING: No Remove Hyperlink option (in context menu) in Impress
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Samuel Mehrbrodt (CIB)
URL:
Whiteboard: target:6.4.0
Keywords:
: 115171 (view as bug list)
Depends on:
Blocks: Context-Menu Hyperlink
  Show dependency treegraph
 
Reported: 2017-08-11 21:09 UTC by Cor Nouws
Modified: 2019-08-12 08:55 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2017-08-11 21:09:59 UTC
this contrary to Writer
Comment 1 Jean-Baptiste Faure 2017-08-12 05:30:48 UTC
The hyperlink is removed if you choose "Default Formatting".

Best regards. JBF
Comment 2 Buovjaga 2017-08-30 12:25:04 UTC
(In reply to Jean-Baptiste Faure from comment #1)
> The hyperlink is removed if you choose "Default Formatting".

Is Cor happy with this?
Comment 3 Cor Nouws 2017-08-30 15:38:49 UTC
(In reply to Buovjaga from comment #2)
> (In reply to Jean-Baptiste Faure from comment #1)
> > The hyperlink is removed if you choose "Default Formatting".
> 
> Is Cor happy with this?

representing the discussion in bug 31766: no.

See https://bugs.documentfoundation.org/show_bug.cgi?id=31766#c4
and https://bugs.documentfoundation.org/show_bug.cgi?id=31766#c18

etc
The idea is that Clear direct formatting will _not_ remove hyperlinks - and this an extra menu is needed, as is available in Writer :)
Comment 4 Buovjaga 2017-08-30 15:46:15 UTC
Ok, NEW
Comment 5 Timur 2018-01-23 16:20:04 UTC
*** Bug 115171 has been marked as a duplicate of this bug. ***
Comment 6 Samuel Mehrbrodt (CIB) 2019-07-08 10:29:53 UTC
Needs some work still.
Removing a link will remove all links in the current text box. Instead it should only remove the selected link.
Comment 7 Commit Notification 2019-07-09 07:22:28 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/5314d69b0b2fa0d04c4562559552ef6b4126d1b1%5E%21

tdf#111707 Only remove the selected hyperlink

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Samuel Mehrbrodt (CIB) 2019-07-09 07:37:55 UTC
Just saw that the first commit notification was missing. This is the commit that introduce this feature:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=533dec5a3ddaff7ec176609edcff2cde4464747a
Comment 9 Commit Notification 2019-07-09 08:52:32 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/7a0164f0d82d91e2ac481d74cdacfe9a7ad6080f%5E%21

tdf#111707 Move duplicated code into shared method

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Buovjaga 2019-07-11 16:15:47 UTC
Verified.

I noticed that the gray field background colour is not removed immediately, but you have to focus away from the text box.

Arch Linux 64-bit
Version: 6.4.0.0.alpha0+
Build ID: 29400185a003bfe9cdbc6e744c4a0d0e40005b03
CPU threads: 8; OS: Linux 5.2; UI render: default; VCL: gtk3; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 11 July 2019
Comment 11 Samuel Mehrbrodt (CIB) 2019-07-11 18:14:24 UTC
(In reply to Buovjaga from comment #10)
> I noticed that the gray field background colour is not removed immediately,
> but you have to focus away from the text box.

Yeah also saw that. Maybe worth adding a separate bug for that?