Bug 111766 - PDF: Brochure mode has small gap between pages
Summary: PDF: Brochure mode has small gap between pages
Status: RESOLVED DUPLICATE of bug 103816
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.0.3 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-08-13 10:56 UTC by Claudio Nieder
Modified: 2018-01-09 11:05 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
The ODT file showing the bad behaviour. (115.25 KB, application/vnd.oasis.opendocument.text)
2017-08-13 10:57 UTC, Claudio Nieder
Details
Created PDF file, where you can see on PDF page 2, that the line above document pages 2 and 3 has a small gap. (117.28 KB, application/pdf)
2017-08-13 10:58 UTC, Claudio Nieder
Details
Screenshot of left hand end of border line on page 2 (1.33 KB, image/png)
2017-08-16 07:30 UTC, Alex Thurgood
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Claudio Nieder 2017-08-13 10:56:02 UTC
Description:
I have a document having on opposite pages frames with a line which goes to the border. While in page preview it looks fine, when generating a PDF in brochure mode there is a gap in the line.

As a side note: If the print dialog is opened a first time and brochure mode is enable then closed and opened again, the preview is totally wrong, only after deselecting and reselecting brochure mode it looks right.

Find attached the ODT document as well as the PDF so you can reproduce the issue on your side.

Steps to Reproduce:
1. Open attached ODT
2. Open print dialog
3. Select brochure mode
4. Observe on the second page (holding page 2 and 3 of the brochure) that there is a small gap in the line on top of the two pages.
5. Create PDF and observe that the line is broken.

Actual Results:  
The line across pages 2 and 3 of the brochure has a small gap.

Expected Results:
The line across pages 2 and 3 of the brochure should be continuous.


Reproducible: Always

User Profile Reset: Yes, and the issue is still visible.

Additional Info:


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_6) AppleWebKit/603.3.8 (KHTML, like Gecko) Version/10.1.2 Safari/603.3.8
Comment 1 Claudio Nieder 2017-08-13 10:57:17 UTC
Created attachment 135513 [details]
The ODT file showing the bad behaviour.
Comment 2 Claudio Nieder 2017-08-13 10:58:36 UTC
Created attachment 135514 [details]
Created PDF file, where you can see on PDF page 2, that the line above document pages 2 and 3 has a small gap.
Comment 3 Alex Thurgood 2017-08-16 07:29:31 UTC
@Claudio:

I see a gap on the left hand side with the border line of the frame of page 2 in the ODT, cf. enclosed screenshot.
Comment 4 Alex Thurgood 2017-08-16 07:30:00 UTC
Created attachment 135576 [details]
Screenshot of left hand end of border line on page 2
Comment 5 Alex Thurgood 2017-08-16 07:31:24 UTC
Tested on 

Version: 5.4.0.3
Build ID: 7556cbc6811c9d992f4064ab9287069087d7f62c
CPU threads: 4; OS: Mac OS X 10.12.6; UI render: default; 
Locale: fr-FR (fr_FR.UTF-8); Calc: group
Comment 6 Alex Thurgood 2017-08-16 07:33:19 UTC
(In reply to Claudio Nieder from comment #0)
> Description:


> As a side note: If the print dialog is opened a first time and brochure mode
> is enable then closed and opened again, the preview is totally wrong, only
> after deselecting and reselecting brochure mode it looks right.
> 

Please open a separate bug report for this behaviour.
Comment 7 Alex Thurgood 2017-08-16 07:36:34 UTC
IMO, the problem seems to be that the frame can't be positioned on the left hand edge of the page. I have tried selecting the frame and moving it leftwards with the mouse or the keyboard and nothing happens, so it seems that there is a mismatch between left hand page limit as displayed (and printed) and the limit at which you can set the frame (and corresponding border).
Comment 8 Alex Thurgood 2017-08-16 07:43:48 UTC
Possibly a DUP of 103816 in regard to frame margin ?
Comment 9 Alex Thurgood 2017-08-17 13:07:07 UTC

*** This bug has been marked as a duplicate of bug 103816 ***
Comment 10 Claudio Nieder 2017-08-19 11:30:18 UTC
(In reply to Alex Thurgood from comment #3)
> @Claudio:
> 
> I see a gap on the left hand side with the border line of the frame of page
> 2 in the ODT, cf. enclosed screenshot.

For me it looks though like the gap you see is smaller than the gap when printed. So there might be even two issues here.
Comment 11 Xisco Faulí 2018-01-09 11:04:09 UTC

*** This bug has been marked as a duplicate of bug 65067 ***
Comment 12 Xisco Faulí 2018-01-09 11:05:25 UTC

*** This bug has been marked as a duplicate of bug 103816 ***