Bug Hunting Session
Bug 111772 - Macro editor UI very SLOW
Summary: Macro editor UI very SLOW
Status: RESOLVED DUPLICATE of bug 107944
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.3.5.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: perf
Depends on:
Blocks:
 
Reported: 2017-08-13 16:52 UTC by Pierre C
Modified: 2017-08-18 17:06 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pierre C 2017-08-13 16:52:35 UTC
On My LapTop, the graphic card is not OpenGL compatible. So OpenGL is disabled, and Hardware acceleration is enabled.

I'm using the macro editor witch is very slow. Selecting text with the mouse, moving screen, is very (very) slow. (unusable)

For example, with a macro code of 60 lines, only 30 lines are visible on the screen. If I select all the text from the end to the top, that mean scrolling over 30 lines, this takes over 25 seconds with LO 5.4.0.3 or MasterDev LO 6. And over 20 seconds with LO 5.3.5.2

With AOO, this is immediate. I haven't tried with older LO than 5.3

Running Windows 10 x64 and LO x64. Latest  graphic drivers, NVidia GeFORCE 710M

Pierre
Comment 1 Jean-Baptiste Faure 2017-08-13 20:38:14 UTC
Not reproducible for me with LO 5.4.2.0.0+ built at home under Ubuntu 16.04 x86-64.

Best regards. JBF
Comment 2 raal 2017-08-14 07:00:38 UTC
I can not confirm. Version: 6.0.0.0.alpha0+
Build ID: b6e32d53ce9c98bfba517c40f53d40e97a091b0e
CPU threads: 4; OS: Windows 6.1; UI render: default;
Comment 3 Pierre C 2017-08-14 07:33:19 UTC
Test must be done with OpenGL disabled and HW acceleration enabled.

I've made some tests on my laptop. I can switch between NVidia and Intel integrate graphic card.
With Intel card (HD Graphics 4000), things are slightly better, but still slower than AOO.

When selecting text with mouse, each time en new character is selected, we can see the screen redrawing/refreshing.

Maybe this bug is related to : https://bugs.documentfoundation.org/show_bug.cgi?id=110741
Comment 4 Xisco Faulí 2017-08-15 17:06:10 UTC Comment hidden (obsolete)
Comment 5 Luis 2017-08-16 12:11:35 UTC
When you select text in macro editor, after each change in selection the full screen is redrawed. 
In my case this is a bit slow but the behaviour is not optimal.

Version: 5.4.1.0.0+ (x64)
Build ID: b78c398817940bbbe0b9ebe848a923cef1856758
CPU threads: 2; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86_64@62-TDF, Branch:libreoffice-5-4, Time: 2017-07-28_09:02:44
Locale: es-ES (es_ES); Calc: group
Comment 6 Luis 2017-08-16 12:14:12 UTC
Same results regardless of the state of OpenGL or HW acceleration.
Comment 7 Luis 2017-08-16 12:42:16 UTC
I think this bug is the same as bug 107944.
Comment 8 Pierre C 2017-08-18 15:42:55 UTC
I did a test with :
Version: 6.0.0.0.alpha0+ (x64)
Build ID: bec5a2ac82b5178f6e765494c2003febe8ab51da
CPU threads: 4; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2017-08-12_23:35:00
Locale: fr-FR (fr_FR); Calc: CL

Fresh profile, and same problem

Comment #5 describes exactly the behavior
Comment 9 Jean-Baptiste Faure 2017-08-18 17:06:29 UTC
(In reply to Luis from comment #7)
> I think this bug is the same as bug 107944.

You are right. Closing as duplicate.

Best regards. JBF

*** This bug has been marked as a duplicate of bug 107944 ***