Bug Hunting Session
Bug 111823 - Form control : Linked cell can't be read upon opening ods format
Summary: Form control : Linked cell can't be read upon opening ods format
Status: RESOLVED DUPLICATE of bug 110431
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.4.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2017-08-15 20:44 UTC by refhi
Modified: 2017-08-20 15:48 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
3 tests Form Control linked with A1 A2 & A3 (8.97 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-08-15 20:44 UTC, refhi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description refhi 2017-08-15 20:44:15 UTC
Created attachment 135562 [details]
3 tests Form Control linked with A1 A2 & A3

When opening an .ods containing Control Form stuff (Spin buttons and checkboxes, not sure about the others) the "Linked Cell" is not read and is shown empty. And the spin is therefore not changing the value in the cell.

Please note that the value is saved properly but diseapear apon opening the file.

Faulty version = Libreoffice 5.4.x (tested multiple versions of 5.4, on windows 10)
(it worked with 5.3.x)

When opening .xlsx it works as expected though.


The attached file was saved with 5.4.3
=> it is read properly and works with 5.3.5
=> the "Linked cell value" diseapear when read with 5.4.x
Comment 1 raal 2017-08-19 05:16:43 UTC
This seems to have begun at the below commit.
Adding Cc: to Mohammed Abdul Azeem; Could you possibly take a look at this one? Thanks


90bca3d4826e7c12e7ce570f5d64fad7482a9b4f is the first bad commit
commit 90bca3d4826e7c12e7ce570f5d64fad7482a9b4f
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Sat Feb 11 11:20:15 2017 -0800

    source sha:8154953add163554c00935486a1cf5677cef2609
author	Mohammed Abdul Azeem <azeemmysore@gmail.com>	2016-09-05 09:08:30 (GMT)
committer	Michael Meeks <michael.meeks@collabora.com>	2017-01-25 11:20:48 (GMT)
commit	8154953add163554c00935486a1cf5677cef2609 (patch)
tree	d8e148e84aa1e164a2358827085f4d9240ce5e31
parent	657eea01046c7f39ee8ca4545241372177385946 (diff)
ScXMLTableRowCellContext implements fast interfaces:
Implementation of fast interfaces for contexts in path from
ScXMLImport::CreateFastContext to ScXMLTableRowCellContext.
FastParser is enabled and duplicates are avoided at all
possible places.
OOoXML filters still need those legacy paths we removed,
so I had to temporarily map them to fast elements, which
would increase their load time, but hopefully it should
help us in the long run.
Comment 2 Xisco Faulí 2017-08-20 15:48:00 UTC

*** This bug has been marked as a duplicate of bug 110431 ***