Bug Hunting Session
Bug 111848 - FILESAVE: errors when saving to PPT/X
Summary: FILESAVE: errors when saving to PPT/X
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.4.0.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-08-16 07:59 UTC by Elmar
Modified: 2017-08-30 16:12 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
source document (219.39 KB, application/vnd.oasis.opendocument.presentation)
2017-08-16 08:00 UTC, Elmar
Details
save to ppt (396.00 KB, application/vnd.ms-powerpoint)
2017-08-16 08:01 UTC, Elmar
Details
save to pptx (227.15 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2017-08-16 08:02 UTC, Elmar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Elmar 2017-08-16 07:59:48 UTC
Description:
Version: 5.4.1.0.0+
Build ID: 6622ea7365fbf1b425e5f90667dd7e6466fd0293
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:libreoffice-5-4, Time: 2017-07-21_06:37:51
Locale: en-ZA (en_ZA.UTF-8); Calc: group

I create presentations on a weekly basis and have to save many to PPT/X. These days, there is hardly ever a reason to massage the output. Though I do admit, I avoid fancy stuff and stick to the basics, so WELL DONE guys! THANK YOU!

There are some issues though, which should be easy to fix (compare PPT and PPTX - problem mostly when save to PPTX):

1. TABS are lost in transition (see slide 7 in examples)
2. Font size in the empty rows is not as in original (slide 7)
3. When shrink text to fit box, this is lost in PPTX (to fix, I choose Master, then the all come right when I click on one of them)
4. Page number is lost in footer, and ti does not place it in the the same place as the original. This may be because PPTX has a whole bunch of Master pages for different formats which are created automatically, but the slide no is not propagated to the additional master pages.


Actual Results:  
see the example files

Expected Results:
see the example files - compare ODP to PPT and PPTX


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0
Comment 1 Elmar 2017-08-16 08:00:57 UTC
Created attachment 135577 [details]
source document

original document
Comment 2 Elmar 2017-08-16 08:01:43 UTC
Created attachment 135578 [details]
save to ppt
Comment 3 Elmar 2017-08-16 08:02:30 UTC
Created attachment 135579 [details]
save to pptx

this is the one that has the most issues.
Comment 4 Xisco Faulí 2017-08-16 09:00:27 UTC
Hello Elmar,
Thank you very much for reporting this.
Could it be possible you report each problem in a different bug instead of many problems in the same bug?
This make bugs triaging much easier to the QA team.OTOH, check for duplicates before reporting new bugs.
Comment 5 Buovjaga 2017-08-30 16:12:38 UTC
All right, looks like Elmar opened bug 111857 + bug 111858 + bug 111859 + bug 111860 for this. Closing.