Bug 111882 - Small fail rendering antialised font at end of word/paragraf.
Summary: Small fail rendering antialised font at end of word/paragraf.
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
5.4.0.3 release
Hardware: x86 (IA32) Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: VCL-OpenGL DirectWrite
  Show dependency treegraph
 
Reported: 2017-08-17 12:40 UTC by Luis
Modified: 2017-11-16 06:47 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample image of File menu (26.68 KB, image/png)
2017-08-17 12:40 UTC, Luis
Details
Sample image of dialog (6.07 KB, image/png)
2017-08-17 12:41 UTC, Luis
Details
Sample image of calc screen. (10.41 KB, image/png)
2017-08-18 07:35 UTC, Luis
Details
New sample image of dialog (20.56 KB, image/png)
2017-08-21 11:36 UTC, Luis
Details
Comparison of text in list box (10.01 KB, image/png)
2017-08-21 21:12 UTC, Luis
Details
Detail of rendering in Firefox. (29.00 KB, image/png)
2017-08-22 07:26 UTC, Luis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luis 2017-08-17 12:40:35 UTC
Created attachment 135619 [details]
Sample image of File menu

In some cases the last character of text has an small fail rendering the rigthmost part. The last pixel line is not crisp (or maybe omited).
Attachet two samples.
First sample is file menu (see zoomeed end of "Save All").
Second sample is a BASIC dialog with two buttons. The first button has text "Acabado en l" and the l is not crisp. The second button has text "Acabado en l " (added space after the 'l' character) and is correctly rendered.

Tested with:

Version: 5.4.1.0.0+ (x64)
Build ID: b78c398817940bbbe0b9ebe848a923cef1856758
CPU threads: 2; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86_64@62-TDF, Branch:libreoffice-5-4, Time: 2017-07-28_09:02:44
Locale: es-ES (es_ES); Calc: group
Comment 1 Luis 2017-08-17 12:41:08 UTC
Created attachment 135620 [details]
Sample image of dialog
Comment 2 Xisco Faulí 2017-08-17 14:13:53 UTC Comment hidden (obsolete)
Comment 3 Luis 2017-08-18 07:34:30 UTC
After reset profile the issue remains.

Looks as the issue arises using Font Tahoma with size <= 8 (¿used in user interface?)

I have attached a new image from calc:
Fill cells with "l", "ll", "lll", "llll" and "lllll" using Tahoma 8, Tahoma 9 and Liberation Sans 6. 
The issue only surfaces with Tahoma 8.
Comment 4 Luis 2017-08-18 07:35:32 UTC
Created attachment 135639 [details]
Sample image of calc screen.
Comment 5 Buovjaga 2017-08-21 09:52:35 UTC
Confirmed.

Win 7 Pro 64-bit Version: 6.0.0.0.alpha0+ (x64)
Build ID: bec5a2ac82b5178f6e765494c2003febe8ab51da
CPU threads: 4; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2017-08-12_23:35:00
Locale: fi-FI (fi_FI); Calc: CL
Comment 6 Aron Budea 2017-08-21 11:17:37 UTC
Looks a bit like bug 111307.
Comment 7 Luis 2017-08-21 11:33:19 UTC
I have found a screen with a more dramatic effect. See "MB" and "hh:mm" in then new attachment.

Some tidbits:

In Windows 7 the default theme (Aero) uses in the UI the Segoe UI font of size 9. With this font the issue is not present.

If theme is changed to Classic Windows then the UI uses the Tahoma font of size 8. With this font the issue is present.
Comment 8 Luis 2017-08-21 11:36:50 UTC
Created attachment 135695 [details]
New sample image of dialog
Comment 9 Luis 2017-08-21 11:40:08 UTC
Hi Aron,

I agree with comment 6. For me it looks related.
Comment 10 Buovjaga 2017-08-21 11:52:28 UTC
(In reply to Aron Budea from comment #6)
> Looks a bit like bug 111307.

In that bug they are cut from the left side.
Comment 11 Luis 2017-08-21 21:12:19 UTC
Created attachment 135713 [details]
Comparison of text in list box

Tested in Windows 8.1

I have created a dialog with a list box control using font Tahoma size 8.
Then capture the control with diferent setings.

1) OpenGL enabled (use HW acel. can not be selected)

2) OpenGL disabled, HW aceleration enabled 

3) OpenGL disabled, HW aceleration disabled

All options show similar results (see attachement with zoomed text).
Comment 12 Luis 2017-08-22 07:26:19 UTC
Created attachment 135718 [details]
Detail of rendering in Firefox.

I notice that LO renders antialiased text in gray tones but
other applications renders text in color tones. 
New sample attachment is from Firefox.
Comment 13 Aron Budea 2017-11-05 23:25:47 UTC
Seems to be fixed in master and in 5.4.3.2.
Comment 14 Buovjaga 2017-11-16 06:47:45 UTC
Yep, closing

Version: 6.0.0.0.alpha1+ (x64)
Build ID: a5af0fd9f27af42cf2e8571f659cdad6e606215b
CPU threads: 4; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2017-11-07_00:30:02
Locale: fi-FI (fi_FI); Calc: CL