Bug 111895 - FILEOPEN: DOCX: Images and other components hidden
Summary: FILEOPEN: DOCX: Images and other components hidden
Status: RESOLVED DUPLICATE of bug 104602
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.0.0
Keywords: filter:docx, regression
Depends on:
Blocks: DOCX-Images 111899
  Show dependency treegraph
 
Reported: 2017-08-18 08:07 UTC by web
Modified: 2017-09-05 07:40 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Original document (1.09 MB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-08-18 08:10 UTC, web
Details
Screenshot of doc in Google (190.42 KB, image/jpeg)
2017-08-18 08:12 UTC, web
Details
background.odt: simple example document shows regression (19.37 KB, application/vnd.oasis.opendocument.text)
2017-08-29 20:54 UTC, Justin L
Details

Note You need to log in before you can comment on or make changes to this bug.
Description web 2017-08-18 08:07:43 UTC
Description:
I have been sent some documents that have images and boxes around text. The images do not appear when I open the documents in Writer.

Steps to Reproduce:
1. Open document
2.
3.

Actual Results:  
Images are hidden

Expected Results:
Images should be visible


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:55.0) Gecko/20100101 Firefox/55.0
Comment 1 web 2017-08-18 08:10:03 UTC
Created attachment 135640 [details]
Original document
Comment 2 web 2017-08-18 08:12:44 UTC
Created attachment 135641 [details]
Screenshot of doc in Google
Comment 3 Xisco Faulí 2017-08-18 14:33:11 UTC
Confirmed in

Version: 6.0.0.0.alpha0+
Build ID: a19dc104ec008f0bb44676d63d4764c6d7442a0d
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

- Version: 5.2.0.0.alpha1+
Build ID: 5b168b3fa568e48e795234dc5fa454bf24c9805e
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8)

- Version: 5.0.0.0.alpha1+
Build ID: 0db96caf0fcce09b87621c11b584a6d81cc7df86
Locale: ca-ES (ca_ES.UTF-8)

in

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

one image is displayed but I wouldn't consider this a regression



Textboxes not displayed in master has been reported in bug 111899
Comment 4 Jacques Guilleron 2017-08-20 16:15:32 UTC
Hi @all,

Observed:
When the background color is deleted, the whole content becomes visible.
Most of the images are imported, wrongly I think, as Contour.
Comment 5 Commit Notification 2017-08-28 15:55:11 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d21f67fa7fd0360688e083eeb2bbcd57f5414d71

tdf#111895 writerfilter: avoid hiding shapes behind background

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Jacques Guilleron 2017-08-29 13:53:32 UTC
Hi Justin,

Works fine for images with
LO 6.0.0.0.alpha0+ Build ID: 9420391cc9f6af2a16c1db72596f277439df29e9
CPU threads: 2; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2017-08-29_06:08:06
Locale: fr-FR (fr_FR); Calc: CL

However, the black rounded rectangles still stay in background.
When I delete this setting, they come again to the right place.
Is it workable to apply the same treatment as for images?

Thank you.

Jacques
Comment 7 Justin L 2017-08-29 20:54:50 UTC
Created attachment 135855 [details]
background.odt: simple example document shows regression

I think my fix handled things the wrong way. Thanks to various comments, I tried bibisecting with this document which points to huge 4.4 patch 
commit	7d9bb549d498d6beed2c4050c402d09643febdfa   2014-06-02 15:00:50 (GMT)
Related: #i124638# Second step of DrawingLayer FillAttributes...
for Writer objects, now added support for Paragraph and PageStyle (including
Header and Footer) for direct attributes and style attributes

The thing to note is that before this 4.4 patch when you put the object "wrap through in background", you are still in front of the page background. After the 4.4 patch, you disappear behind it, but only for DOCX.  In ODT and in DOC, you don't disappear behind it...
Comment 8 Justin L 2017-08-30 22:33:25 UTC
Will will be reverting the patch in comment 5.

This is better solved with the patch for bug 104602.

*** This bug has been marked as a duplicate of bug 104602 ***
Comment 9 Commit Notification 2017-09-04 17:26:31 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=24e453e6018af2e71af784dc9364b5ea70112f29

Revert "tdf#111895 writerfilter: avoid hiding shapes behind background"

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Jacques Guilleron 2017-09-05 07:40:49 UTC
Hi Justin,

Black rounded rectangles are visible now with
LO 6.0.0.0.alpha0+ Build ID: 342622d51f457c5a7d5026814a323d1deece4681
CPU threads: 2; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2017-09-05_04:43:20
Locale: fr-FR (fr_FR); Calc: CL
Thank you very much for the work.