Bug Hunting Session
Bug 111899 - FILEOPEN: DOCX: textboxes not displayed
Summary: FILEOPEN: DOCX: textboxes not displayed
Status: RESOLVED DUPLICATE of bug 104602
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:docx, regression
Depends on: 111895
Blocks: DOCX-Textbox
  Show dependency treegraph
 
Reported: 2017-08-18 14:26 UTC by Xisco Faulí
Modified: 2017-11-08 04:42 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2017-08-18 14:26:43 UTC
Steps to reproduce:
1. Open attachment 135640 [details] from bug 111895

Observed behaviour: Textboxes aren't displayed

Reproduced in

Version: 6.0.0.0.alpha0+
Build ID: a19dc104ec008f0bb44676d63d4764c6d7442a0d
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 1 Xisco Faulí 2017-08-18 14:28:45 UTC
Regression introduced by:

author	Justin Luth <justin_luth@sil.org>	2017-07-06 18:54:27 (GMT)
committer	Justin Luth <justin_luth@sil.org>	2017-07-15 01:39:26 (GMT)
commit	cc438f60d6ad0855f754dd32da9c9a80c7cabf92 (patch)
tree	13c44745982a0d262096000a09e889d4c3c39c8b
parent	403ddd6cb1c0d6a0e0db105e68f58fe40057cb42 (diff)
tdf#103978 textboxhelper: syncProperty OPAQUE (wrap in background)
Although the containing shape is in the background (and thus the
normal paragraph text is still visible), the shape's text
was still painting over top of the normal paragraph text because
the textbox was set as opaque and not transparent.

Setting the textbox to sync the opacity value of its containing shape.

Bisected with bibisect-linux64-6.0

Adding Cc: to Justin Luth
Comment 2 Justin L 2017-08-23 23:23:11 UTC
It is important to note that bug 111895 indicates that there are many other images in this document that already were missing. Dependent on (and fixed by) bug 111895.

see proposed patch https://gerrit.libreoffice.org/41486
Comment 3 Justin L 2017-08-30 22:53:28 UTC

*** This bug has been marked as a duplicate of bug 104602 ***