Bug 111902 - GTK+ 3 drop-down list buttons are too big (gtk3) -> see screenshots
Summary: GTK+ 3 drop-down list buttons are too big (gtk3) -> see screenshots
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.4.0.3 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: GTK3
  Show dependency treegraph
 
Reported: 2017-08-18 20:16 UTC by Gerry
Modified: 2017-08-24 17:04 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
LibreOffice 5.4 with GTK2, everything is okay here. (98.92 KB, image/png)
2017-08-18 20:19 UTC, Gerry
Details
LibreOffice 5.4 with GTK3, drop-down buttons in the menu bar are too big here. (96.18 KB, image/png)
2017-08-18 20:22 UTC, Gerry
Details
drop-down list height (46.11 KB, application/pdf)
2017-08-19 15:41 UTC, Xavier Van Wijmeersch
Details
drop-down list with gtk2 (35.05 KB, image/png)
2017-08-20 18:59 UTC, Xavier Van Wijmeersch
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gerry 2017-08-18 20:16:54 UTC
Description:
With the GTK+ 3 integration of LibreOffice, the drop-down list buttons are way too big. Please look at the screenshots.


Steps to Reproduce:
1. Install LibreOffice 5.4 (PPA)
2. Install the Ubuntu package "office productivity suite -- GTK+ 3 integration"
3. Restart LibreOffice

Actual Results:  
The drop-down buttons are too big; they look unnatural

Expected Results:
The drop-down buttons should look like in GTK+2


Reproducible: Always

User Profile Reset: No

Additional Info:
GTK3 LibreOffice package:
"office productivity suite -- GTK+ 3 integration" 1:5.4.0~rc3-0ubuntu0.16.04.1~lo1

LibreOffice:
Version: 5.4.0.3
Build-ID: 1:5.4.0~rc3-0ubuntu0.16.04.1~lo1
CPU-Threads: 4; Betriebssystem:Linux 4.4; UI-Render: GL; VCL: gtk2; 
Gebietsschema: de-DE (de_DE.UTF-8); Calc: single

System: Ubuntu Gnome 16.04.3 LTS 64-Bit 
Processor: Intel® Core™ i3-3120M CPU @ 2.50GHz × 4 
Graphics: Intel® Ivybridge Mobile
Screen resolution: 1366x768


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/52.0.2743.82 Safari/537.36
Comment 1 Gerry 2017-08-18 20:19:28 UTC
Created attachment 135648 [details]
LibreOffice 5.4 with GTK2, everything is okay here.
Comment 2 Gerry 2017-08-18 20:22:21 UTC
Created attachment 135649 [details]
LibreOffice 5.4 with GTK3, drop-down buttons in the menu bar are too big here.
Comment 3 Gerry 2017-08-18 20:23:47 UTC
@Caolán + David: I felt free to add you to the bug, as you were working on the GTK+ 3 integration.
Comment 4 Jean-Baptiste Faure 2017-08-18 20:33:40 UTC
What Ubuntu theme are you using? I do not reproduce with default theme (same LO version, same Ubuntu version).

Set status to NEEDINFO, please set it back to UNCONFIRMED once requested
informations are provided.

Best regards. JBF
Comment 5 Gerry 2017-08-18 21:05:32 UTC
Hi Jean-Baptiste, it is the Gnome 3 Adwaita theme
Comment 6 Jean-Baptiste Faure 2017-08-18 21:18:39 UTC
(In reply to Gerry from comment #5)
> Hi Jean-Baptiste, it is the Gnome 3 Adwaita theme

Ok, did not see that your Ubuntu is Ubuntu Gnome, mine is Ubuntu Unity.

Best regards. JBF
Comment 7 Xavier Van Wijmeersch 2017-08-19 10:29:28 UTC
confirm with

Version: 6.0.0.0.alpha0+
Build ID: ec2abbca3d9befc4192452555a9433d267a47d58
CPU threads: 8; OS: Linux 4.9; UI render: default; VCL: gtk3; 
Locale: nl-BE (en_US.UTF-8); Calc: group
Comment 8 Xisco Faulí 2017-08-19 12:27:50 UTC
Moving to NEW as per comment 7.

on Ubuntu 17.04 with Ambiance, dropdown buttons are slightly bigger in gtk3 than in gtk, but not as much as displayed on the screenshots.

Version: 6.0.0.0.alpha0+
Build ID: a19dc104ec008f0bb44676d63d4764c6d7442a0d
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 9 Caolán McNamara 2017-08-19 13:42:39 UTC
Too big vs what ? Too big vs gtk2 isn't a bug as such, too big vs native gtk3 would be a bug, so the issue is the drop down button area is larger than those of a native gtk3 application ?
Comment 10 Xavier Van Wijmeersch 2017-08-19 15:41:13 UTC
Created attachment 135661 [details]
drop-down list height

I made screenshot of the two difference 
maybe this helps to understand the problem
Comment 11 Xisco Faulí 2017-08-20 15:30:08 UTC
(In reply to Xavier Van Wijmeersch from comment #10)
> Created attachment 135661 [details]
> drop-down list height
> 
> I made screenshot of the two difference 
> maybe this helps to understand the problem

Is it the same in other applications with gtk3 or is it different ?
Comment 12 Xavier Van Wijmeersch 2017-08-20 18:58:03 UTC
@Xisco Faulí

I did a build off a gtk2 homebuild LO v6.0.0 and yes there is a difference
see attachment
Comment 13 Xavier Van Wijmeersch 2017-08-20 18:59:04 UTC
Created attachment 135675 [details]
drop-down list with gtk2
Comment 14 Gerry 2017-08-20 20:24:59 UTC
(In reply to Caolán McNamara from comment #9)
> Too big vs what ? Too big vs gtk2 isn't a bug as such, too big vs native
> gtk3 would be a bug, so the issue is the drop down button area is larger
> than those of a native gtk3 application ?

Thanks Caolán for looking into this bug. IMHO, the buttons are too big in following ways:

(1) They look too big, I mean unesthetically big (please look at the screenshot)
(2) As far as I see, they are also bigger than in some other GTK3 applications. Please see this glade screenshot: https://glade.gnome.org/images/glade-main-page.png They seem to be substantially narrower here.
(3) They are certainly much bigger than in gtk2. (if you compare both screenshots).
Comment 15 Adolfo Jayme 2017-08-21 08:09:52 UTC
LibreOffice is just following the theme. Adwaita likes its widgets big; just look at any other application that uses GTK+ 3. (Which makes this report NOTOURBUG by definition.) It’s just the way it was designed.

You can make the widgets more compact by 1) editing the theme’s CSS or 2) switching to any other theme, such as Numix or one of those Ambiance derivatives, for example. You’ll see how everything becomes saner-sized.

W.r.t. Adwaita’s GTK+ 2 theme, that is just a PNG-based hack they came up with, which has never looked quite proper but released because people complained that Clearlooks didn’t match the look of Adwaita for non-GTK+ 3 software. So I wouldn’t regard that as the benchmark against which to compare the rest. But anyway, it’s GNOME’s problem, not ours, that GTK+ 2 and 3 don’t match more closely.
Comment 16 Gerry 2017-08-24 17:04:13 UTC
@Adolfo: Thanks for the information. Indeed, it depends on the GTK3 theme. With Numix the drop down buttons look much better. Adwaita as default Gnome3 theme seems to be not good for LibreOffice's look. Still ugly with Adwaita.

I agree that it is NOTABUG.