Bug 112004 - Tables overlapping when opening DOCX with floating table
Summary: Tables overlapping when opening DOCX with floating table
Status: RESOLVED DUPLICATE of bug 61594
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX-Tables
  Show dependency treegraph
 
Reported: 2017-08-24 12:13 UTC by ghavamikia
Modified: 2019-02-11 15:37 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
screenshot of LO 5.4 (158.23 KB, image/png)
2017-08-25 02:06 UTC, ghavamikia
Details
screenshot word 2016 (145.26 KB, image/png)
2017-08-25 02:06 UTC, ghavamikia
Details
original document (24.88 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-08-25 02:09 UTC, ghavamikia
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ghavamikia 2017-08-24 12:13:22 UTC
Description:
There is a severe problem with the opening of a table from Word 2007 docx file. It opens well on Windows Word 2016 edition but comes out mixed up with overlapping horizontal rows in libreoffice. I cannot attach a screenshot or copy of the original as it contains sensitive information. Has this been documented or reported before? I will try see if I can post a modified version with no information on it if possible at some stage in the future.

Actual Results:  
see above

Expected Results:
see above


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0
Comment 1 ghavamikia 2017-08-25 02:06:16 UTC
Created attachment 135781 [details]
screenshot of LO 5.4
Comment 2 ghavamikia 2017-08-25 02:06:46 UTC
Created attachment 135782 [details]
screenshot word 2016
Comment 3 ghavamikia 2017-08-25 02:09:51 UTC
Created attachment 135783 [details]
original document

of note, when saved as ODT it seems to open ok, it's just the docx filter that needs work it seems
Comment 4 Telesto 2017-08-25 10:35:01 UTC
Confirming with:
Version: 6.0.0.0.alpha0+
Build ID: 02c53f744ed23e2149fc7c83d67cb7d8aa5eb0ed
CPU threads: 4; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-08-24_05:48:55
Locale: nl-NL (nl_NL); Calc: CL

and with
Versie: 4.4.6.3 
Build ID: e8938fd3328e95dcf59dd64e7facd2c7d67c704d
Locale: nl_NL
Comment 5 raal 2017-08-29 14:56:04 UTC
confirmed in comment 4
Comment 6 QA Administrators 2019-02-06 03:50:48 UTC Comment hidden (obsolete)
Comment 7 Timur 2019-02-11 15:35:48 UTC
Not 2007 issue, same if resaved in MSO. Two tables overlapping. This is floating table issue.
No repro LO 3.6, started in 4.0. Repro 6.3+. 
Looks like a duplicate of Bug 69515 (that's not likely to be resolved).

*** This bug has been marked as a duplicate of bug 69515 ***
Comment 8 Timur 2019-02-11 15:37:25 UTC
I meant Bug 61594.

*** This bug has been marked as a duplicate of bug 61594 ***