Bug 112012 - Line in EMF not dashed since new EMF+
Summary: Line in EMF not dashed since new EMF+
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Patrick Jaap
URL:
Whiteboard: target:6.0.0
Keywords:
: 112737 (view as bug list)
Depends on:
Blocks: EMFPlus-Rework-Regressions
  Show dependency treegraph
 
Reported: 2017-08-24 18:12 UTC by Timur
Modified: 2017-10-03 14:46 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Timur 2017-08-24 18:12:59 UTC
Attachment 113379 [details] from bug 89376 is not correct anymore, line is solid instead of dashed.
Probably since new EMF+ so depends on Bug 111486.
Comment 1 V Stuart Foote 2017-08-24 23:03:19 UTC
Confirmed and also while looking at attachment 133111 [details] from bug 31814 showed dashed lines rendered as solid.

On Windows 10 Ent 64-bit en-US with
Version: 6.0.0.0.alpha0+ (x64)
Build ID: 1ba1bb96659d0048bff2a9a15646f6e1e04bd2c4
CPU threads: 8; OS: Windows 6.19; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2017-08-23_00:52:13
Locale: en-US (en_US); Calc: CL
Comment 2 Patrick Jaap 2017-08-25 07:42:17 UTC
Hi, thanks for the feedback! I will look at the regression and hopefully provide a fix soon. Currently, EMF+ only renders solid lines.
Comment 3 Patrick Jaap 2017-09-11 06:46:12 UTC
Update: A working patch is on the way through review process. It will be available in master soon!
Comment 4 Commit Notification 2017-09-15 00:34:08 UTC
Patrick Jaap committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=588c5b0cff9bbdb2efbdfb259268154b0074e7e6

tdf#112012 EMF+ add dashed line support

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 V Stuart Foote 2017-09-15 04:30:32 UTC
On windows 10 Pro 64-bit en-US with
Version: 6.0.0.0.alpha0+ (x64)
Build ID: 031217619cf98fa527ba383938ac49f600d5c5d2
CPU threads: 8; OS: Windows 6.19; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2017-09-15_01:51:03
Locale: en-US (en_US); Calc: CL

Dashed lines look good. Although some interesting inter-dash spacing effects on the now dashed reaction box of attachment 133111 [details] when zooming the canvas in and out.
Comment 6 Patrick Jaap 2017-09-15 14:35:53 UTC
Thanks for the feedback! Indeed, there is something wrong with the spacing of the dashes in your attached emf. The right transformation of the dash length is not completely solved (any help appreciated, see comment #4 patch). I will look at it again, hopefully fixing this issue!
Comment 7 Commit Notification 2017-09-28 20:36:50 UTC
Patrick Jaap committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3b1db9b7a9afe147ed7f841c875bc3b91b03ace9

tdf#112012 EMF+ dashed lines: correct dash length

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Patrick Jaap 2017-09-29 08:44:11 UTC
*** Bug 112737 has been marked as a duplicate of this bug. ***
Comment 9 Timur 2017-09-29 09:43:29 UTC
If fixed, please set as Fixed yourself, so that script counts you properly.