Download it now!
Bug 112029 - FILESAVE, DOC: AutoShape arrow direction changes after roundtrip in Writer
Summary: FILESAVE, DOC: AutoShape arrow direction changes after roundtrip in Writer
Status: RESOLVED DUPLICATE of bug 112247
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
5.4.0.2 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:doc, regression
Depends on:
Blocks: DOC Shapes
  Show dependency treegraph
 
Reported: 2017-08-25 15:01 UTC by Aron Budea
Modified: 2017-09-07 11:57 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample DOC with an arrow (AutoShape) (24.50 KB, application/msword)
2017-08-25 15:01 UTC, Aron Budea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2017-08-25 15:01:24 UTC
Created attachment 135790 [details]
Sample DOC with an arrow (AutoShape)

Open the attached DOC file, it contains a single arrow, an AutoShape copied from the bugdoc in bug 109251 (attachment 134757 [details]).
Save it again as DOC, and open the saved file.

=> The direction changed slightly.

Observed in LO 5.4.0.3 / Windows 7.
Not observed in LO 5.3.0.3.
=> regression
Comment 1 Jacques Guilleron 2017-08-26 11:02:25 UTC
Hi Aron,

I reproduce with
LO 5.4.0.3 (x64) Build ID: 92c2794a7c181ba4c1c5053618179937228ed1fb
Threads CPU : 2; OS : Windows 6.1; UI Render : par défaut; 
Locale : fr-FR (fr_FR); Calc: single
LO 5.4.0.2 Build ID: 2b906d450a44f2bbe506dcd22c51b3fa11dc65fd
Threads CPU : 2; OS : Windows 6.1; UI Render : par défaut; 
Locale : fr-FR (fr_FR); Calc: CL
not with
LO  5.4.0.1 Build ID: 962a9c4e2f56d1dbdd354b1becda28edd471f4f2
Threads CPU : 2; OS : Windows 6.1; UI Render : par défaut; 
Locale : fr-FR (fr_FR); Calc: CL
Comment 2 Aron Budea 2017-08-27 21:22:26 UTC
Interestingly, bibisect-win32-6.0 points to the commit referenced below. I wouldn't have guessed. Adding Cc: to Szymon Kłos, please take a look sometimes.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=d72e0cadceb0b43928a9b4f18d75c9d5d30afdda
author		Szymon Kłos <szymon.klos@collabora.com>	2017-06-19 13:32:16 (GMT)
committer	Andras Timar <andras.timar@collabora.com>	2017-06-28 20:38:49 (GMT)

Watermark: tdf#91687 correct size in the .doc
Comment 3 Szymon Kłos 2017-09-07 11:57:35 UTC
Direction change is caused by increased size. Fix coming soon.

*** This bug has been marked as a duplicate of bug 112247 ***