Download it now!
Bug 112039 - Writer stops responding with high CPU load on opening or editing .DOC with tracked changes
Summary: Writer stops responding with high CPU load on opening or editing .DOC with tr...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.5.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Track-Changes
  Show dependency treegraph
 
Reported: 2017-08-26 07:46 UTC by andis.lazdins
Modified: 2017-09-12 16:17 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample file making writer irresponsive. The same file with accepted changes opens and can be edited fine. (228.00 KB, application/wps-office.doc)
2017-08-26 07:48 UTC, andis.lazdins
Details

Note You need to log in before you can comment on or make changes to this bug.
Description andis.lazdins 2017-08-26 07:46:20 UTC
Description:
Writer stops responding during file open or editing of docx files with tracked changes. It happens every time at some point. There were no problems with these files in Writer 5.2.7.

Steps to Reproduce:
1.Try to open attached file.
2. If file opens try to do some editions with track changes on.

Actual Results:  
1.The file may open and then stop responding during editing or stop responding during opening.
2. Writer can be closed only by killing process.

Expected Results:
Normal edition process


Reproducible: Always

User Profile Reset: No, but I have fresh profile created with switching from 5.2.7 to 5.3.5

Additional Info:


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0
Comment 1 andis.lazdins 2017-08-26 07:48:30 UTC
Created attachment 135802 [details]
Sample file making writer irresponsive. The same file with accepted changes opens and can be edited fine.
Comment 2 andis.lazdins 2017-08-26 07:53:55 UTC
Up to now it looks like the problem is not affecting 5.4.0. File can be opened, but I didn't try to do a lot of editions.
Comment 3 andis.lazdins 2017-08-26 07:58:23 UTC
The problem is affecting 5.3.6.1 too; however, if I open and save file in 5.4.0, it can be opened and edited in 5.3.6 afterwards.
Comment 4 Timur 2017-08-29 15:51:45 UTC
In that case, it's WorksForMe. 
I didn't check myself since you wrote it's working. There was Bug 99692 fixed from 5.3.6.
It's always a good idea to confirm with master that you can get from http://dev-builds.libreoffice.org/daily/master/.
Comment 5 andis.lazdins 2017-08-29 18:46:20 UTC
I hope it is the same problem. Let's hope also that the solution will be implemented in 5.3.6 and enterprise users will not have to wait until 5.4.5 or another version recommended for enterprises will come up.
Thank you for pointing to another bug.
Comment 6 Timur 2017-08-30 16:19:37 UTC
I see that you are a longtime and active user. You probably know that answer to your dilemma is either to wait and see either to bibisect it. 
This project is in need of volunteers to bibisect so you may consider to start with that.
Comment 7 andis.lazdins 2017-09-05 05:13:07 UTC
(In reply to Timur from comment #6)
> This project is in need of volunteers to bibisect so you may consider to
> start with that.
Sorry to say, but now it's very problematic due to shortage of time. This test requires at least 15 minutes for a version. I'll try to do it in October. 5.4.1 has other issues so the problems with track changes are rather painful.
Comment 8 andis.lazdins 2017-09-12 04:46:51 UTC
I was not able to realize bibisect using instructions from here https://wiki.documentfoundation.org/QA/Bibisect. Either my English knowledge are too poor or instructions are outdated. But I installed several libreoffice versions in parallel.

It looks like the problem is with my profile, because I was not able to repeat this bug in parallel installation. Couldn't find if it relates to some extension or settings. 

This will be already 2nd time during last 2 months, when I have to create new profile because of the profile related problems in 5.3.x, but the bug probably can be closed.