Download it now!
Bug 112066 - The CJK text position is incorrect under vertical text direction mode
Summary: The CJK text position is incorrect under vertical text direction mode
Status: RESOLVED DUPLICATE of bug 111967
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: CJK
  Show dependency treegraph
 
Reported: 2017-08-28 10:52 UTC by cyanshrike
Modified: 2017-09-09 19:10 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
correct position (2017-08-15_00.23.07) (91.29 KB, image/png)
2017-08-28 10:54 UTC, cyanshrike
Details
incorrect position (2017-08-15_23.49.00) (91.34 KB, image/png)
2017-08-28 10:55 UTC, cyanshrike
Details
Sample document file (9.96 KB, application/vnd.oasis.opendocument.text)
2017-08-28 10:56 UTC, cyanshrike
Details

Note You need to log in before you can comment on or make changes to this bug.
Description cyanshrike 2017-08-28 10:52:28 UTC
Description:
After update to '2017-08-15_23.49.00' daily build from '2017-08-15_00.23.07' daily build, the CJK text position is incorrect under vertical text direction mode.


Steps to Reproduce:
1. Open writer to create a new text document
2. Change text direction to 'Right-to-left (vertical)'
3. Input multiple cjk text lines


Actual Results:  
CJK text goes out of paragraph

Expected Results:
CJK text is in the right position


Reproducible: Always

User Profile Reset: Yes

Additional Info:
Debian Linux package: libreoffice (1:5.4.0-1~bpo9+1) also has this problem


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0
Comment 1 cyanshrike 2017-08-28 10:54:30 UTC
Created attachment 135823 [details]
correct position (2017-08-15_00.23.07)
Comment 2 cyanshrike 2017-08-28 10:55:05 UTC
Created attachment 135824 [details]
incorrect position (2017-08-15_23.49.00)
Comment 3 cyanshrike 2017-08-28 10:56:56 UTC
Created attachment 135825 [details]
Sample document file
Comment 4 Buovjaga 2017-09-09 13:38:18 UTC
Confirmed.

Looking at the range of commits, this HarfBuzz update springs to mind as the potential cause: https://cgit.freedesktop.org/libreoffice/core/commit/?id=5aab2900dfdc9f12adda378470149670a2a069df

Arch Linux 64-bit, KDE Plasma 5
Version: 6.0.0.0.alpha0+
Build ID: a27eb931c22313d4dd5c73b35358c0532d20b79e
CPU threads: 8; OS: Linux 4.12; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on September 8th 2017
Comment 5 Xisco Faulí 2017-09-09 19:10:19 UTC
Regression introduced by 5aab2900dfdc9f12adda378470149670a2a069df. Same as in bug 111967

*** This bug has been marked as a duplicate of bug 111967 ***