Bug 112094 - FIELDS: Font of file name changes on saving as a .docx file
Summary: FIELDS: Font of file name changes on saving as a .docx file
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.6.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: DOCX-Fields
  Show dependency treegraph
 
Reported: 2017-08-29 22:07 UTC by Bob Furber
Modified: 2019-04-01 13:29 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Font of footer file-name field changes on saving (6.32 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-08-29 22:07 UTC, Bob Furber
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bob Furber 2017-08-29 22:07:34 UTC
Created attachment 135856 [details]
Font of footer file-name field changes on saving

Unlike 94190, only the footer file-name field changes on saving.

To reproduce:

1. Open attached UnpredictableFooterFormatting1.docx in LibreOffice Writer

2. Change the font in the file-name field in the footer to Arial to match the rest of the footer

3. Save and close file

4. Re-open the file

5. The file-name field in the footer has changed to Times-New-Roman font
Comment 1 Dieter Praas 2017-09-03 08:56:13 UTC
I could reproduce it with your document. I also did the following test:
1. Open your document
2. Copy the file-name field
3. Paste it in the text (not in the footer)
4. Save as docx, close and reopen

Result: Complete text has changed to TNR (except the datum)

Further test:
1. Use the document from test 1
2. Delete the file-name field in the footer
3. Change the font to Arial
4. Save as docx, close and reopen

Result: File-name field has changed to TNR

=> so I think the bug is more related to file-name field than to footer
=> I changed the summary
Comment 2 QA Administrators 2019-04-01 03:24:34 UTC Comment hidden (obsolete)
Comment 3 Dieter Praas 2019-04-01 13:29:26 UTC
I can't reproduce it with

Version: 6.2.2.2 (x64)
Build-ID: 2b840030fec2aae0fd2658d8d4f9548af4e3518d
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: threaded

=> RESOLVED WORKSFORME