Download it now!
Bug 112104 - Digital signature of .odt files with with hardware token (Hungarian eID) is not working
Summary: Digital signature of .odt files with with hardware token (Hungarian eID) is n...
Status: RESOLVED DUPLICATE of bug 109180
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.4.0.3 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-08-30 12:49 UTC by Daniel Sutto
Modified: 2018-06-12 10:51 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Test pdf that was successfully signed with hardware token. (58.59 KB, application/pdf)
2017-08-30 12:55 UTC, Daniel Sutto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Sutto 2017-08-30 12:49:53 UTC
Description:
I try to digitally sign LibreOffice documents using the Hungarian eID. Signing of pdf documents works properly, but LibreOffice crashes when signing an .odt.


It is possible to sign both document types with software keys (pkcs#12) using the same signature altorithm.

I was using Debian testing/buster (amd64) image.

Steps to Reproduce:
1. Install middleware application (eSzemélyi Kliens)
2. Load /usr/bin/eszig-pkcs11.so as Secuirty Device in Firefox preferences
3. Create a simple document with Writer, save it.
4. Open Digital Signatures dialog (File->Digital Signatures->Digital Signatures)
5. Click Sign Document, enter eSign PIN of the previously connected eID card.
6. Select certificate and click OK

Actual Results:  
Libre Office crashes before any command is sent to the card.

Expected Results:
The document should have been signed.


Reproducible: Always

User Profile Reset: No

Additional Info:
If the document is exported as pdf, and File->Digital Signatures->Sign existing pdf is selected, the PAdES digital signature can be added to the pdf document.

Hungarian eID is a hardware based token, PKCS#11 library is installed as a part of "eSzemélyi Kliens", which can be downloaded from https://eszemelyi.hu/letoltesek

Sample card can be provided by Ministery of Interior (eszemelyi-szerver@bm.gov.hu) or directly by Idomsoft (eid-szerver@idomsoft.hu).


User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:55.0) Gecko/20100101 Firefox/55.0
Comment 1 Daniel Sutto 2017-08-30 12:55:22 UTC
Created attachment 135869 [details]
Test pdf that was successfully signed with hardware token.
Comment 2 Xisco Faulí 2018-06-12 10:51:27 UTC
Thanks for reporting the issue.
I'd say, this is a dupe of bug 109180.

Could you please try to reproduce it with a master build from http://dev-builds.libreoffice.org/daily/master/ ?
You can install it alongside the standard version.

*** This bug has been marked as a duplicate of bug 109180 ***