Bug 112121 - fileopen .jp2 [ jpeg 2000 ] crash
Summary: fileopen .jp2 [ jpeg 2000 ] crash
Status: RESOLVED DUPLICATE of bug 99347
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Android Viewer (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha0+
Hardware: ARM Android
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-08-31 05:44 UTC by vihsa
Modified: 2019-11-08 17:46 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
test file (61.08 KB, image/jp2)
2017-08-31 05:44 UTC, vihsa
Details

Note You need to log in before you can comment on or make changes to this bug.
Description vihsa 2017-08-31 05:44:57 UTC
Created attachment 135892 [details]
test file

observed behaviour: libreoffice viewer 5.4 crashes

open attachment test file

fileopen results:

**garbage**
5.0.0.0.alpha1+ [ build id: ab465b9 ]
5.1.0.0.alpha1+ [ build id: 1a6ec13 ]
5.1.0.0.alpha1+ [ build id: 5b791ec ]
5.2.0.0.alpha0+ [ build id: f6a74ce ]

**endless loop**
5.3.0.0.alpha1+ [ build id: 4136757 ]

**crash**
5.4.0.0.alpha0+ [ build id: 3902bb7 ]

os: android 5.1
device: lyf flame 3 [ ls-4001 ]
Comment 1 raal 2017-09-15 21:16:01 UTC
confirm. Version: 6.0.0.0.alpha0+
Build ID: e038dfd
Comment 2 QA Administrators 2018-09-16 02:48:50 UTC Comment hidden (obsolete)
Comment 3 Christian Lohmaier 2019-11-08 17:46:05 UTC
wfm - Android Viewer doesn't claim to support jpeg 2000 / jp2 files and doesn't offer to open them.

LibreOffice as a whole doesn't support jpeg2000, thus setting as duplicate.

*** This bug has been marked as a duplicate of bug 99347 ***