Bug Hunting Session
Bug 112159 - Saving a spreadsheet in Excel format (xls or xlsx) dates are formated chinese (taiwan)
Summary: Saving a spreadsheet in Excel format (xls or xlsx) dates are formated chines...
Status: RESOLVED DUPLICATE of bug 113889
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.4.0.3 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 114004 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-09-01 13:37 UTC by Joachim Behrendt
Modified: 2018-11-26 14:31 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joachim Behrendt 2017-09-01 13:37:22 UTC
Description:
Saving a spreadsheet  in Excel format (xls or xlsx) dates (20.09.17) are formated chinese (taiwan) 09.20.17.
I have checked the Version 5.4.1.2 in Linux /Ubuntu 16.04 and Windows 7 Pro

Steps to Reproduce:
1. create a new spreadsheet with libre office calc
2. enter a date where the day is bigger thean 12 (20.09.17) 
   and formata as date german (deutschland)
3. save the spreadsheed as exclefile xls or xlsx
4. open the file with excel than the date-format has changed 09.20.17 
5. if you check the formating you see chinese (taiwan)

Actual Results:  
09.20.17

Expected Results:
20.09.17


Reproducible: Always

User Profile Reset: Other colleagues has reproduced this bug as well

Additional Info:
This bug doesn't exit for Libreoffice 5.3 and only for 5.4.1.2 


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0
Comment 1 m.a.riosv 2017-09-01 20:54:44 UTC
Seems it lose the language for date format, in my case it returns to my default Spanish.

Version: 5.4.1.2 (x64)
Build ID: ea7cb86e6eeb2bf3a5af73a8f7777ac570321527
CPU threads: 4; OS: Windows 6.19; UI render: default; 
Locale: es-ES (es_ES); Calc: group
Comment 2 jmgigandet 2017-10-25 07:39:31 UTC
Same thing here.
French locale, and dates are shown in English Caribean locale when opening files saved with LO (5.4.1 or 5.4.2, Windows 7 pro X64 and MacOSX 11) in Microsoft Excel.
For me importance should have been major, as we cannot exchange files containing dates with Microsoft Excel users.
Comment 3 m.a.riosv 2017-11-23 12:02:34 UTC
*** Bug 114004 has been marked as a duplicate of this bug. ***
Comment 4 QA Administrators 2018-11-24 03:44:31 UTC Comment hidden (obsolete)
Comment 5 Roman Kuznetsov 2018-11-26 14:31:21 UTC
looks as duplicate of bug 113889

*** This bug has been marked as a duplicate of bug 113889 ***