Bug 112179 - SLIDESHOW: black-out and white-out not working properly in fullscreen presenter mode
Summary: SLIDESHOW: black-out and white-out not working properly in fullscreen present...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 135095 (view as bug list)
Depends on:
Blocks: Slide-Show
  Show dependency treegraph
 
Reported: 2017-09-02 15:58 UTC by Piotr Porada
Modified: 2020-07-27 20:01 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Piotr Porada 2017-09-02 15:58:29 UTC
Description:
Black-out and white-out functionalities do not work properly on macOS Sierra.

After entering fullscreen presentation mode with secondary monitor attached primary monitor shows presenter console and secondary monitor shows current slide. Black-out and white-out shortcuts do not work unless I click directly on the slide on the secondary monitor.

Problem occurs only on macOS. Tried the same version on a Windows PC and it worked correctly

Steps to Reproduce:
1. Open a slideshow with two monitors attached
2. Enter slideshow (eg. F5)
3. Press B or W key

Actual Results:  
Nothing happens unless the slide on the actual slideshow is clicked

Expected Results:
Actual slideshow is blacked-out (B key) or whited-out (W key)


Reproducible: Always

User Profile Reset: Yes - started in Safe Mode, problem still occurs

Additional Info:
Computer affected is a Macbook Air 11" (Early 2015) with up-to-date updates installed

The other computer I tried is a Lenovo Y50-70 with Win 8.1 (from factory image) also with up-to-date updates installed.

Problem occurs regardless of which slideshow is opened.


User-Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.113 Safari/537.36
Comment 1 Alex Thurgood 2017-09-04 07:39:00 UTC
Pretty certain this is a duplicate.
Comment 2 Alex Thurgood 2017-09-04 07:51:18 UTC
Can't find the earlier report after quick search. Setting to NEW
Comment 3 m.a.riosv 2017-09-18 00:06:15 UTC
*** Bug 112398 has been marked as a duplicate of this bug. ***
Comment 4 QA Administrators 2018-09-19 02:51:43 UTC Comment hidden (obsolete)
Comment 5 Piotr Porada 2018-09-19 20:26:12 UTC
As per instructions from Comment#4:

This bug is still present in the following version:

Version: 6.1.1.2
Build ID: 5d19a1bfa650b796764388cd8b33a5af1f5baa1b
CPU threads: 4; OS: Mac OS X 10.13.6; UI render: default; 
Locale: pl-PL (pl_PL.UTF-8); Calc: group threaded

The "About..." window also contains the link to the following commit: https://gerrit.libreoffice.org/gitweb?p=core.git&a=log&h=5d19a1bfa650b796764388cd8b33a5af1f5baa1b

I also tested with version 3.3.0.4 - the bug is present there, so I will mark the version, as inherited from OOo. The oldest version from the archive is:

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 6 Andrew Watson 2020-07-25 11:04:30 UTC
Bug still present in:

Version: 7.0.0.2
Build ID: c01aa64b6c3d89ebe5fe69c28c7adb24eb85249c
CPU threads: 4; OS: Mac OS X 10.11.6; UI render: default; VCL: osx
Locale: en-GB (en_GB.UTF-8); UI: en-GB
Calc: threaded
Comment 7 Andrew Watson 2020-07-25 11:15:18 UTC
*** Bug 135095 has been marked as a duplicate of this bug. ***