Download it now!
Bug 112200 - Vertical page prints with text horizontally
Summary: Vertical page prints with text horizontally
Status: RESOLVED DUPLICATE of bug 92190
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.2.3.3 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-09-03 20:15 UTC by rairose.cornell
Modified: 2017-10-24 19:31 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
vertical page always prints with text horizontal (507.50 KB, image/png)
2017-09-03 20:15 UTC, rairose.cornell
Details
Version info (87.00 KB, image/png)
2017-09-03 20:45 UTC, rairose.cornell
Details
I downloaded the correct version. (724.48 KB, image/png)
2017-09-04 18:24 UTC, rairose.cornell
Details
But it's still printing improperly. (699.44 KB, image/png)
2017-09-04 18:25 UTC, rairose.cornell
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rairose.cornell 2017-09-03 20:15:49 UTC
Created attachment 135988 [details]
vertical page always prints with text horizontal

I've created a document in LibreOffice Vanilla (version 5.2.3.5) in a vertical page orientation. It's a single page and I want to print it. But when I do, it prints horizontally with the bottom part of my content cut off. This problem occurs in every single document that I create in the program. I've tried changing the page orientation, I've edited the print settings, and I've tried setting everything back to default. Still, nothing works. I've attached a screenshot of the problem.
Comment 1 Jean-Baptiste Faure 2017-09-03 20:26:33 UTC
Version 5.2.3.5 does not exist. What is the correct number ?
Currents versions are 5.3.6 (Stable) and 5.4.1 (Fresh).

Set status to NEEDINFO, please set it back to UNCONFIRMED once requested
informations are provided.

Best regards. JBF
Comment 2 rairose.cornell 2017-09-03 20:45:09 UTC
Created attachment 135989 [details]
Version info

That's the version number that shows up. Here is a screenshot of the "About" info.
Comment 3 Jean-Baptiste Faure 2017-09-04 04:26:34 UTC
Ok, I see, you are using a version build and provided by Collabora instead of the  version provided by the project LibreOffice. I suggest you to try with a recent official version downloaded from LibreOffice website. That will allow to decide if the problem is on the main project side or the Collabora side.

Best regards. JBF
Comment 4 Alex Thurgood 2017-09-04 07:27:03 UTC
@Cornell : Collabora LibreOffice Vanilla available from the AppStore has a number of particular bugs different to the versions of LibreOffice available from the TDF download website.

The version you are using is old and obsolete (in comparison to currently available versions of LibreOffice). Please try with a current production release of LibreOffice from TDF.

Also note that previous issues with Landscape printing when wanting Portrait are also known, so if your issue persists with a current production release, then this report is almost certainly a DUPLICATE of the existing issue (and will probably be marked as such).

Setting NEEDINFO pending requested testing and reporting back by original bug reporter. Please set back to UNCONFIRMED with your findings after testing as indicated above.
Comment 5 rairose.cornell 2017-09-04 18:24:37 UTC
Created attachment 136014 [details]
I downloaded the correct version.

I deleted the old version of LibreOffice Vanilla from my computer. Then I downloaded the new version from the proper source.
Comment 6 rairose.cornell 2017-09-04 18:25:38 UTC
Created attachment 136015 [details]
But it's still printing improperly.

But it's still printing improperly.
Comment 7 rairose.cornell 2017-09-04 18:26:51 UTC
I deleted the old version of LibreOffice Vanilla from my computer. Then I downloaded the correct version (see first attachment). However, when I try to print a document, the same problem is still occurring. I tried it with several different documents, and it happens every time. I've looked through the forum, but I can't find another thread that gives instructions on how to fix this.
Comment 8 Alex Thurgood 2017-09-05 08:02:49 UTC
@Cornell : thanks for your feedback. Currently, the only workaround that I know of is to change the page settings slightly. This problem seems to manifest itself with Letter page size defaults in certain templates. Changing the page size slightly circumvents the problem, allowing the page to be printed correctly, however, the bug is indeed there.
Comment 9 Alex Thurgood 2017-09-05 08:08:31 UTC

*** This bug has been marked as a duplicate of bug 92190 ***
Comment 10 rayseto 2017-10-24 19:31:39 UTC
This bug has been present across multiple newer versions of LibreOffice.  Will it be resolved soon?  Thanks for the current workaround.