Download it now!
Bug 112220 - FILESAVE XLSX: Cell Indent Increases on Each Save
Summary: FILESAVE XLSX: Cell Indent Increases on Each Save
Status: RESOLVED DUPLICATE of bug 130104
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.3.5.2 release
Hardware: All Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:xlsx, possibleRegression
Depends on:
Blocks: XLSX
  Show dependency treegraph
 
Reported: 2017-09-05 02:10 UTC by Kevin Suo
Modified: 2020-02-25 13:54 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Test xlsx file (4.95 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2017-09-05 02:10 UTC, Kevin Suo
Details
screenshot showning the comparison (246.81 KB, image/png)
2018-02-04 02:48 UTC, Kevin Suo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Suo 2017-09-05 02:10:39 UTC
Created attachment 136020 [details]
Test xlsx file

The attached xlsx file contains cells with indent text. On each edit and save, the indent value increases.

Steps to Reproduce:
1. Open the Attached XLSX. Notice the indent width of the cell values.
2. Do any editing in some blank cells, then save and reopen.
3. Repeat several times.

Bug Behaviour:
The indent value increases on each save.

Expected:
The indent value remains the same.

Version: 5.3.5.2
Build ID:5.3.5.2-3.fc26
CPU 线程:4; 操作系统:Linux 4.12; UI 渲染:默认; VCL: gtk3; Layout Engine: new; 
Locale: zh-CN (zh_CN.UTF-8); Calc: group
Fedora 26 x64
Comment 1 Kevin Suo 2017-09-05 02:11:36 UTC
Increase the importance a little bit as it causes format loss.
Comment 2 Xavier Van Wijmeersch 2017-09-05 07:34:17 UTC
confirm with

Version: 6.0.0.0.alpha0+
Build ID: 9c165fe3084b7c054f9f04f3b065897abcbe2162
CPU threads: 8; OS: Linux 4.9; UI render: default; VCL: kde4; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-09-02_23:12:31
Locale: nl-BE (en_US.UTF-8); Calc: group
Comment 3 Kevin Suo 2017-09-05 11:05:39 UTC
Set to NEW according to comment 2.
It's a possible regression.
Comment 4 Xisco Faulí 2017-09-07 08:13:06 UTC
How many times do you have to save it to see the issue?

I've tried 4 times and the result is the same

Version: 6.0.0.0.alpha0+
Build ID: 383aab7ed63bf30931c1cf89138707d2228b5dce
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 5 Kevin Suo 2017-09-07 11:28:03 UTC
(In reply to Xisco Faulí from comment #4)
Each save will cause the indent increase by the value equal to the first time you open it, so you may observe the difference after 2 or 3 times.

By the way, I am using Fedora 26 with Gnome desktop.
Comment 6 Kevin Suo 2017-11-07 02:29:42 UTC
Bug 62878 is about the indent change by value*3 on save, and was RESOLVED as NOTOUTBUG because of OOXML limitation. I am adding it as see also.

However this bug 112220 is about the indent increase on each re-save. Indent change on first save should be an ooxml limitation, but the indent increase on each save should be a bug.
Comment 7 Bartosz 2018-02-04 00:07:18 UTC
I'm not able to fix that with LO 5.4.4 on Ubuntu 16.04
I have tried several times resaving, but the indentation width is the same.
Could you please give step by step instruction how to reproduce this bug?
How many times you need to resave file?
Comment 8 Kevin Suo 2018-02-04 01:33:37 UTC
(In reply to Bartosz from comment #7)
The steps are as simple as stated in the original report. 3 times resave is enough to see the increase in indent.

Will provide a screenshot.

This may be OS specific. @Xavier Van Wijmeersch what is your OS?
Comment 9 Kevin Suo 2018-02-04 01:46:31 UTC
To reproduce, you should resave it as XLSX, not ODS.
Comment 10 Kevin Suo 2018-02-04 02:48:09 UTC
Created attachment 139565 [details]
screenshot showning the comparison

Bug already appear in:

Version: 5.4.0.0.alpha0+
Build ID: c0d4aadf08c16f2d79508367c631366f7a856346
CPU Threads: 2; OS Version: Linux 4.14; UI Render: default; VCL: gtk3; Layout Engine: new; 
Locale: zh-CN (zh_CN.UTF-8); Calc: group
Comment 11 Xavier Van Wijmeersch 2018-02-04 11:25:15 UTC
@Kevin Suo

My OS is slackware64 current and LO is home build every week
Before i have not these problems but maybe because i use openjdk 9 and 10-ea to build LO master and LO 6.0.1.0; gcc 7.3.0; mesa 17.3.3
Comment 12 QA Administrators 2019-02-05 03:46:05 UTC Comment hidden (obsolete)
Comment 13 jdobry 2020-02-25 12:43:57 UTC
This issue still valid on actual version.
See https://bugs.documentfoundation.org/show_bug.cgi?id=130104
Comment 14 Kevin Suo 2020-02-25 13:54:35 UTC
Let's mark this one as a duplicate of bug 130104 as that one was already bibisected and bisected.

*** This bug has been marked as a duplicate of bug 130104 ***