Bug Hunting Session
Bug 112236 - EDITING: Erroneous error message when renaming a sheet to blank
Summary: EDITING: Erroneous error message when renaming a sheet to blank
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.4.1.2 release
Hardware: All Windows (All)
: medium minor
Assignee: Roman Kuznetsov
URL:
Whiteboard: target:6.3.0 target:6.2.0.1
Keywords:
Depends on:
Blocks: Error-Messages
  Show dependency treegraph
 
Reported: 2017-09-05 14:51 UTC by Emil Tanev
Modified: 2018-12-08 18:45 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot of the error message (66.98 KB, image/png)
2017-09-05 14:51 UTC, Emil Tanev
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Emil Tanev 2017-09-05 14:51:31 UTC
Created attachment 136035 [details]
screenshot of the error message

Open a new spreadsheet
Double clik in the sheet tab so as to edit its name
Delete the default Sheet1
Press OK

Issue: The error message does not include the case of Blank name. It only mentions no duplicate and not containing any of a set of symbols.
https://www.screencast.com/t/exbaRILz8wD
Comment 1 raal 2017-09-06 15:50:11 UTC
Confirm
Comment 2 QA Administrators 2018-09-07 02:43:51 UTC Comment hidden (obsolete)
Comment 3 Roman Kuznetsov 2018-12-07 21:22:24 UTC
still repro in 6.3 alpha 0

May be just change message in warning dialogue to

"Invalid sheet name.
The sheet name must not be an empty or a duplicate of an existing name, 
and may not contain the characters [ ] * ? : / \ 
or the character ' (apostrophe) as first or last character."
Comment 4 Eike Rathke 2018-12-07 21:49:29 UTC
Seriously?
I mean, explicitly mention that a sheet name can not be empty, isn't that a bit overdone? The same one could argue that when renaming a file the file name can't be empty..
Comment 5 Roman Kuznetsov 2018-12-08 06:37:02 UTC
(In reply to Eike Rathke from comment #4)
> Seriously?
> I mean, explicitly mention that a sheet name can not be empty, isn't that a
> bit overdone? The same one could argue that when renaming a file the file
> name can't be empty..

Absolutely. This question is "I see error message, but text in it don't speak me about my case (empty name)". Therefore I offer just to add text of error.
Comment 6 Commit Notification 2018-12-08 15:44:16 UTC
Roman Kuznetsov committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/06fae15c8c7aac7a6d50f1f3cf635f6ae3355bda%5E%21

tdf#112236 Enhance error message when renaming a sheet to blank

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2018-12-08 18:45:45 UTC
Roman Kuznetsov committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/ea3a02210cb0798c2c65b840aeca44f98ef6ce93%5E%21

tdf#112236 Enhance error message when renaming a sheet to blank

It will be available in 6.2.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.