Bug Hunting Session
Bug 112247 - FILESAVE: DOC: shape increases in size every time it is saved
Summary: FILESAVE: DOC: shape increases in size every time it is saved
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Szymon Kłos
URL:
Whiteboard: target:6.0.0 target:5.4.3
Keywords: bibisected, bisected, regression
: 112029 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-09-05 20:53 UTC by Justin L
Modified: 2017-09-19 11:36 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
linesGrowFatterWhenSaving.doc: round-tripping increases the height every time. (48.00 KB, application/msword)
2017-09-05 20:53 UTC, Justin L
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Justin L 2017-09-05 20:53:07 UTC
Created attachment 136045 [details]
linesGrowFatterWhenSaving.doc: round-tripping increases the height every time.

Every round-trip, the horizontal lines in this unit test get fatter by 0.09inches.

Regression in LO 6.0 (and backported to 5.4). Introduced for bug 91687 by author Szymon Kłos 2017-06-28 20:38:49 (GMT) in commit d72e0cadceb0b43928a9b4f18d75c9d5d30afdda
>Watermark: tdf#91687 correct size in the .doc
Comment 1 Xisco Faulí 2017-09-05 22:13:17 UTC
Adding Cc: to Szymon Kłos
Comment 2 Szymon Kłos 2017-09-07 11:57:35 UTC
*** Bug 112029 has been marked as a duplicate of this bug. ***
Comment 3 Commit Notification 2017-09-07 13:12:59 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=91d909ac8ec53ea135401babe8227f9c41b779b8

tdf#112247 correct the size only for Watermark

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Jacques Guilleron 2017-09-09 09:29:34 UTC
Hi all,

Works fine with
LO 6.0.0.0.alpha0+ Build ID: a45800f010f3e063c6f31426fcdba76aa5b43d3e
CPU threads: 2; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2017-09-09_00:43:08
Locale: fr-FR (fr_FR); Calc: CL
Thank you very much, Szymon.
Comment 5 Commit Notification 2017-09-19 11:36:58 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c7fe1daf67e99beea78fee8d7cef70443ff4e54f&h=libreoffice-5-4

tdf#112247 correct the size only for Watermark

It will be available in 5.4.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.