Bug Hunting Session
Bug 112299 - Combobox broken after opening the file
Summary: Combobox broken after opening the file
Status: RESOLVED DUPLICATE of bug 110431
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.4.0.3 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2017-09-09 08:51 UTC by frederic-scherer
Modified: 2017-09-09 18:23 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
example of the bug, with screenshots (19.16 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-09-09 08:52 UTC, frederic-scherer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description frederic-scherer 2017-09-09 08:51:27 UTC
Description:
With older versions of Calc, I used Comboboxes (form controls) on sheets.
If I open these files, the comboboxes don't work anymore:
- the linked cell doesn't change if I change the combobox selection
- the appearance of the combobox has changed

Steps to Reproduce:
1. in a sheet, place a combobox with linked cells as input and output
2. set the dropdown attribute to yes
3. save and close the file
4. reopen the file

Actual Results:  
see decription

Expected Results:
the appearance of the combobox shouldn't have changed, the linked cell should still be linked.


Reproducible: Always

User Profile Reset: No beacuse it is reproducible on all computers I've tested (3)

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0
Comment 1 frederic-scherer 2017-09-09 08:52:43 UTC
Created attachment 136133 [details]
example of the bug, with screenshots
Comment 2 Jacques Guilleron 2017-09-09 15:19:21 UTC
Hi Frederic,

Some combobox properties are no longer read:
General tab: Dropdown to No
Data tab : Linked cell is empty
When those setting are corrected, all works.

Works as expected in LO 5.3.6.1

I reproduce with
LO 5.4.0.0.alpha0+ Build ID: 789ed159fb03eef26c991f361380d0eb7b509cd9
CPU Threads: 2; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-02-03_01:06:06
Locale: en-US (fr_FR); Calc: CL
and all upper versions

but not with
LO 5.4.0.0.alpha0+ Build ID: 5903235d57acb13d9d5286d23b443a01aeab9a3c
CPU Threads: 2; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-12-19_00:08:35
Locale: fr-FR (fr_FR); Calc: CL
Comment 3 raal 2017-09-09 18:23:10 UTC
90bca3d4826e7c12e7ce570f5d64fad7482a9b4f is the first bad commit
commit 90bca3d4826e7c12e7ce570f5d64fad7482a9b4f
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Sat Feb 11 11:20:15 2017 -0800

    source sha:8154953add163554c00935486a1cf5677cef2609

author	Mohammed Abdul Azeem <azeemmysore@gmail.com>	2016-09-05 09:08:30 (GMT)
committer	Michael Meeks <michael.meeks@collabora.com>	2017-01-25 11:20:48 (GMT)
commit	8154953add163554c00935486a1cf5677cef2609 (patch)
tree	d8e148e84aa1e164a2358827085f4d9240ce5e31
parent	657eea01046c7f39ee8ca4545241372177385946 (diff)
ScXMLTableRowCellContext implements fast interfaces:
Comment 4 raal 2017-09-09 18:23:57 UTC

*** This bug has been marked as a duplicate of bug 110431 ***