Download it now!
Bug 112302 - Select All doesn't select All objects
Summary: Select All doesn't select All objects
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.4.1.2 release
Hardware: x86-64 (AMD64) All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Selection
  Show dependency treegraph
 
Reported: 2017-09-09 10:21 UTC by kie000
Modified: 2018-09-12 21:39 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kie000 2017-09-09 10:21:46 UTC
Description:
Copied this table to calc (using Chrome, not IE or Firefox):
https://en.wikipedia.org/wiki/List_of_countries_by_population_growth_rate

Control-A to select all, also tried select all on edit menu

Backspace to bring up deletion menu

Ticked only object box, clicked ok, nothing happens, objects were not selected.

There does not seem to be a method to select all objects or even 2 objects.

Steps to Reproduce:
1.Select All
2.
3.

Actual Results:  
Does not select all

Expected Results:
Select all should select all


Reproducible: Always

User Profile Reset: N/A

Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: SpreadsheetDocument
[Information guessed from browser]
OS: Windows (All)
OS is 64bit: yes
Builds ID: LibreOffice 5.4.1.2


User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:55.0) Gecko/20100101 Firefox/55.0
Comment 1 Thomas Lendo 2017-09-09 23:21:43 UTC
Interesting. Copied to another Calc file the flags can be deleted but not in the file where the wiki table data is inserted.

The image xml code in content.xml file is:
<draw:frame draw:z-index="1" draw:name="https://upload.wikimedia.org/wikipedia/commons/thumb/3/36/Flag_of_Albania.svg/21px-Flag_of_Albania.svg.png" draw:style-name="gr1" draw:text-style-name="P1" svg:width="5.55mm" svg:height="3.96mm" svg:x="0mm" svg:y="1106.31mm"><draw:image xlink:href="https://upload.wikimedia.org/wikipedia/commons/thumb/3/36/Flag_of_Albania.svg/21px-Flag_of_Albania.svg.png" xlink:type="simple" xlink:show="embed" xlink:actuate="onLoad"><text:p/></draw:image></draw:frame>
Comment 2 Buovjaga 2017-09-11 06:29:53 UTC
Yeah.

Arch Linux 64-bit, KDE Plasma 5
Version: 6.0.0.0.alpha0+
Build ID: 09122a537318f7ada075820f3b1ef83a64e56751
CPU threads: 8; OS: Linux 4.12; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on September 10th 2017
Comment 3 QA Administrators 2018-09-12 02:37:36 UTC Comment hidden (obsolete)
Comment 4 Roman Kuznetsov 2018-09-12 12:23:10 UTC
in 

Версия: 6.1.1.1
ID сборки: 2718b4a18dfcc6a54ebe5f7b801ee7a47fa81e0c
Потоков ЦП: 4; ОС:Windows 6.1; Отрисовка ИП: по умолчанию; 
Локаль: ru-RU (ru_RU); Calc: group threaded

deleting only objects from spreadsheet works fine

Status -> WFM
Comment 5 kie000 2018-09-12 20:49:39 UTC
Previous commenter was not addressing the issue.

Control-A to select all, does not select objects and subsequently hitting delete does not therefore delete objects.

Selecting everything should select EVERYTHING.
Comment 6 Roman Kuznetsov 2018-09-12 21:13:01 UTC
(In reply to kie000 from comment #5)
> Previous commenter was not addressing the issue.
> 
> Control-A to select all, does not select objects and subsequently hitting
> delete does not therefore delete objects.
> 
> Selecting everything should select EVERYTHING.

I follow your steps :

Control-A to select all, also tried select all on edit menu Backspace to bring up deletion menu Ticked only object box, clicked ok, >>>nothing happens<<<, objects were not selected.

But for me all flags were deleted in 6.1.

If objects were deleted, then it were selected by Ctrl+A.
Comment 7 Buovjaga 2018-09-12 21:39:51 UTC
(In reply to kie000 from comment #5)
> Previous commenter was not addressing the issue.
> 
> Control-A to select all, does not select objects and subsequently hitting
> delete does not therefore delete objects.
> 
> Selecting everything should select EVERYTHING.

Works for me both ways:
1. Delete all deletes all, including flags
2. Delete only objects deletes only flags

A year ago I still saw the problem.

Arch Linux 64-bit
Version: 6.1.0.3
Build ID: 6.1.0-2
CPU threads: 8; OS: Linux 4.18; UI render: default; VCL: gtk3_kde5; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group threaded