Bug 112324 - Instant Preview not applicable for Fonts in Writer
Summary: Instant Preview not applicable for Fonts in Writer
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.0.3 release
Hardware: x86 (IA32) Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 115398 122368 (view as bug list)
Depends on:
Blocks: Font-Preview
  Show dependency treegraph
 
Reported: 2017-09-11 10:28 UTC by ajimady
Modified: 2018-12-30 11:30 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Screen shot for font face to change (242.73 KB, image/png)
2017-09-11 10:28 UTC, ajimady
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ajimady 2017-09-11 10:28:04 UTC
Created attachment 136166 [details]
Screen shot for font face to change

In Writer not applicable instant preview for Fonts (Size,Color,Highlights,Face)before applying to Selected words.


Step 1: Open LibreOffice Writer
Step 2: Type any words or sentence (Ex:Welcome to LibreOffice)
Step 3: Select the words or sentence
Step 4: Click the font Face tab and view the different types of faces, before applying to change it do not show the preview.
Step 5: Repeat the step 4 for font Size, font Color and font Highlights.


Environment:

LibreOffice 5.4.0.3
Windows 7 (32 bit)
Comment 1 Dieter Praas 2017-09-11 11:03:07 UTC
I confirm this, but I'm not sure if it is possible to provide such a preview.
Comment 2 Heiko Tietze 2017-09-11 11:23:05 UTC
You screenshot shows the font name rendered as the font looks. This dropdown will not modify any other property like size or color. The full preview is limited to the left hand paragraph style dropdown or the styles list at the sidebar. If you define a character style with a certain font name, -size, and -color it will be shown full WYSIWYG there.

If you expect to get immediate feedback when the selection changes this issue is kind of duplicate of bug 112175.
Comment 3 V Stuart Foote 2017-09-11 13:19:43 UTC
Yes, WFM.  But note that the requested feature is handled via tabs of the Character dialog--applied as direct formatting, or when working up a paragraph style.
Comment 4 ajimady 2017-09-14 07:48:15 UTC
I am detailing here with one more example. 

1. If you have Microsoft Word, Please open.  
2. Type "LibreOffice". 
3. Select the typed content.  
4. Now move the cursor to Font Size / Font Face 
5. Select in the drop down - any Font Size Example: 18
6. The font size is updated with the selected one before we apply.  

Now, try the same in LibreOffice Writer.  

1. Open LibreOffice Writer. 
2. Type "LibreOffice". 
3. Select the typed content.  
4. Now move the cursor to Font Size / Font Face 
5. Select in the drop down - any Font Size Example: 18
6. The font size is NOT updated with the selected one before we apply.
Comment 5 ajimady 2017-09-14 07:50:31 UTC
(In reply to V Stuart Foote from comment #3)
> Yes, WFM.  But note that the requested feature is handled via tabs of the
> Character dialog--applied as direct formatting, or when working up a
> paragraph style.

Hi, 
Please go through my latest comment.  Your suggestion is different from the feature what I am thinking about.  Because, what you suggested is available in both Writer and MS Word.  What I raised here is not present in LibreOffice Writer.  Please correct me if I am wrong.
Comment 6 Heiko Tietze 2017-09-22 14:22:52 UTC
We talked about this request in the design meeting. The decision was to not recommend this behavior. Changes in dropdown controls should not get applied unless the user clicks an entry or leaves the control (i.e. tab) because of safety and performance. We wrote a guideline now that should describe the intended behavior: https://wiki.documentfoundation.org/Design/Selection

Sorry that your idea is not accept.
Comment 7 Heiko Tietze 2018-02-15 23:43:24 UTC
*** Bug 115398 has been marked as a duplicate of this bug. ***
Comment 8 Mike Kaganski 2018-12-26 09:28:35 UTC
I'd like to point out the inconsistency with Calc in this regards. It shows the live preview in the selected cell. Do you think it needs addressing to meet the guidelines?
Comment 9 V Stuart Foote 2018-12-29 17:09:00 UTC
*** Bug 122368 has been marked as a duplicate of this bug. ***
Comment 10 Heiko Tietze 2018-12-30 11:30:24 UTC
(In reply to Mike Kaganski from comment #8)
> I'd like to point out the inconsistency with Calc in this regards. It shows
> the live preview in the selected cell. Do you think it needs addressing to
> meet the guidelines?

Wouldn't make the guideline too complicated but have some exceptions. The default is no preview with Calc having some.