Download it now!
Bug 112335 - Link to Places from Dolphin on Ukrainian letters don't work correctly in LO save file menu on KDE Plasma
Summary: Link to Places from Dolphin on Ukrainian letters don't work correctly in LO s...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.0 all versions
Hardware: x86-64 (AMD64) Linux (All)
: low minor
Assignee: Not Assigned
URL:
Whiteboard: kde4
Keywords:
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2017-09-11 18:59 UTC by AlexBez
Modified: 2019-01-01 19:18 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Visual coments (127.59 KB, image/png)
2017-09-11 19:18 UTC, AlexBez
Details

Note You need to log in before you can comment on or make changes to this bug.
Description AlexBez 2017-09-11 18:59:56 UTC
Description:
when I am in "Save-LibreOffice" menu and try to open link in "Places" that was created in "Dolphin" in Ukrainian layout, than link works in the wrong way. The link shows only folders that containe the same text in English, but instead Ukrainian letters there are question marks.

Steps to Reproduce:
1.I create a link "Інна" in a folder "Places" of "Dolphin": "/home/van/Data/Інна/"
2.I click the link "Інна" in a folder "Places" of "Save-LibreOffice" menu 
3.In the right side of "Save-LibreOffice" opens folder "/home/van/Data/" instead of "/home/van/Data/Інна/"

Actual Results:  
the right folder doesn't open. link "Інна" in a folder "Places" of "Save-LibreOffice" menu looks like "file:///home/van/Data/????/" instead of "file:///home/van/Data/Інна/"

Expected Results:
the right folder must be opened in the right side of "Save-LibreOffice" menu 


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0
Comment 1 AlexBez 2017-09-11 19:18:24 UTC
Created attachment 136178 [details]
Visual coments
Comment 2 AlexBez 2017-09-11 19:23:48 UTC
This bug affected in all linux distro with KDE. I checked it on Kubuntu, Linux Mint KDE, Debian 9 KDE, openSUSE 42.x KDE
Comment 3 Xisco Faulí 2017-09-14 09:29:32 UTC
You can't confirm your own bugs. Moving it back to UNCONFIRMED until someone else confirms it.
Comment 4 Buovjaga 2017-10-28 14:58:11 UTC
(In reply to AlexBez from comment #0)
> 1.I create a link "Інна" in a folder "Places" of "Dolphin":
> "/home/van/Data/Інна/"

This is done by right-clicking the Інна folder and selecting Add to places.

I reproduce the problem. Note that there is a KDE5 integration in development: https://cgit.freedesktop.org/libreoffice/core/log/?h=feature/kde5
Let's hope it fixes the problem.

Arch Linux 64-bit, KDE Plasma 5
Version: 6.0.0.0.alpha1+
Build ID: 7a2e7c32d38db02aaa5d78d5e8aaf86cabfde586
CPU threads: 8; OS: Linux 4.13; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on October 28th 2017
Comment 5 Buovjaga 2019-01-01 19:18:39 UTC
Good news: this works with the new kde5 backend!

Arch Linux 64-bit
Version: 6.3.0.0.alpha0+
Build ID: 2c7b0030b40de00e8c9ab997bdfe83631861968a
CPU threads: 8; OS: Linux 4.20; UI render: default; VCL: kde5; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 1 January 2019